Opened 7 years ago

Closed 7 years ago

#8189 closed defect (not a bug)

Control port says LAUNCHED after it says EXTENDED

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: robgjansen Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In handle_control_extendcircuit() when the controller asks Tor to make a circuit, it ends with

  connection_printf_to_buf(conn, "250 EXTENDED %lu\r\n",
                             (unsigned long)circ->global_identifier);
  if (zero_circ) /* send a 'launched' event, for completeness */
    control_event_circuit_status(circ, CIRC_EVENT_LAUNCHED, 0);

It is weird that we say EXTENDED before we say LAUNCHED.

Also, how come we say EXTENDED right when we hear the EXTEND request from the controller, rather than when a hop gets completed?

Reported by Rob.

Child Tickets

Change History (3)

comment:1 in reply to:  description ; Changed 7 years ago by arma

Cc: robgjansen added

Replying to arma:

It is weird that we say EXTENDED before we say LAUNCHED.

Not that weird actually: it is 250 EXTENDED, and 650 CIRC 122 LAUNCHED, and later 650 CIRC 122 EXTENDED.

Also, how come we say EXTENDED right when we hear the EXTEND request from the controller, rather than when a hop gets completed?

"because it is a control protocol response, not an event"

Ok to close as not-a-bug, Rob?

comment:2 in reply to:  1 Changed 7 years ago by robgjansen

Replying to arma:

Ok to close as not-a-bug, Rob?

Yes. This makes sense.

comment:3 Changed 7 years ago by arma

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.