Opened 6 years ago

Closed 6 years ago

#8216 closed defect (fixed)

BBC iPlayer renders weirdly

Reported by: cypherpunks Owned by: MB
Priority: Medium Milestone: HTTPSE Cr 2013.4.2x
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: #6975 Points:
Reviewer: Sponsor:

Description

Using the HTTPS Everywhere plugin on the site www.bbc.co.uk/iplayer causes the site to render badly. I believe that this is a bug in the BBC handling of the request but it appears that the site should be added to a whitelist.

N.B. I believe that the BBC uses GeoIP locating to differentiate between UK and non-UK addresses so different results may be found when testing this from outside the UK.

Child Tickets

Attachments (1)

BBC iPlayer Bug.tiff (255.1 KB) - added by cypherpunks 6 years ago.
Rendering bug with cookies displayed

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by pde

Keywords: httpse-ruleset-bug added
Owner: changed from pde to MB
Status: newassigned
Summary: httpse-ruleset-bug BBC iPlayerBBC iPlayer

MB, can you look at this? I don't have a shell or proxy handy in the UK.

comment:2 Changed 6 years ago by pde

Summary: BBC iPlayerBBC iPlayer renders weirdly

comment:3 Changed 6 years ago by martin__

Chrome or Firefox? Which version of https everywhere? With or without using Tor Browser Bundle? Does it already happen on the first time you load www.bbc.co.uk/iplayer ?

Could not reproduce problem with Firefox 18.0.2 on Ubuntu with https everywhere 4.0development.5 from outside the UK.
Could not reproduce problem with Chrome 24.0.1312.69 on Ubuntu with https everywhere 2013.1.18 from outside the UK.

Could not reproduce problem with TorBrowserBundle (Firefox 10.0.12 ESR), neither with 

StrictNodes 1
ExitNodes {gb}

(recognized as being in the UK), nor from outside the UK.

comment:4 in reply to:  description Changed 6 years ago by MB

Status: assignedneeds_information

Replying to cypherpunks:

Using the HTTPS Everywhere plugin on the site www.bbc.co.uk/iplayer causes the site to render badly.

I see nothing amiss. You'll need to be more specific.

comment:5 Changed 6 years ago by cypherpunks

Hi

I am using google Chrome Version 24.0.1312.57 on a MacBook 4,1 system version 10.7.5 and the EFF Https everywhere plugin from the chrome app store.

Since you had trouble replicating this I wiped all Chrome data from my account thereby delating all extensions, cookies and settings. I then loaded the https everywhere plugin again and went to www.bbc.co.uk/iplayer from a UK internet connection. Surprisingly I then found that the page appeared fine but upon refreshing it it rendered badly again with a complaint that a browser with CSS support was needed to show the page. Using the inspect chrome tool I found a single cookie being placed on the initial visit. One of the values stored in this cookie is "BBC-UID", deleting the BBC-UID value caused the page to be rendered properly again after refresh. The problem appears again in subsequent refreshes.

Changed 6 years ago by cypherpunks

Attachment: BBC iPlayer Bug.tiff added

Rendering bug with cookies displayed

comment:6 Changed 6 years ago by pde

Hypothesis: this might be an insance of #7492, which is wildly overdue for a fix. I've started working on it, despite theoretically being on vacation.

comment:7 Changed 6 years ago by pde

Can anyone report whether this problem is still occurring?

comment:8 Changed 6 years ago by cypherpunks

Hi

I can confirm this issue is still present as described previously with latest Chrome version and latest chrome web store HTTPS Everywhere plugin

comment:9 Changed 6 years ago by pde

Milestone: HTTPSE Cr 2013.4.1x

comment:10 Changed 6 years ago by pde

Parent ID: #6975
Resolution: fixed
Status: needs_informationclosed

This was a simple instance of #6975, sorry for not being on it sooner.

Note: See TracTickets for help on using tickets.