Opened 7 years ago

Closed 7 years ago

#8218 closed defect (fixed)

Authorities mark every relay as down-for-an-hour at every restart

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-auth
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In https://trac.torproject.org/projects/tor/ticket/1035#comment:40 I reported

Jul 07 14:08:27.000 [info] rep_hist_note_router_reachable(): Router BFA1BA13CAC96F8C13689FE1FDC65359ED6AC6D7 still seems Running, but its address appears to have changed since the last time it was reachable.  I'm going to treat it as having been down for 7200 seconds

I see those in practice on moria1 still:

$ grep -i "still seems" moria1-info|grep "Feb 12"|wc -l
501

The issue is this code:

  addr_changed = at_addr &&
    tor_addr_compare(at_addr, &hist->last_reached_addr, CMP_EXACT) != 0;
  port_changed = at_port && at_port != hist->last_reached_port;

where last_reached_foo always starts out empty, so the first comparison always shows a change.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by arma

Status: newneeds_review

See my bug8218 branch.

comment:2 Changed 7 years ago by nickm

Looks okay. Did you test it?

comment:3 Changed 7 years ago by arma

Resolution: fixed
Status: needs_reviewclosed

I've been happily running it on moria1.

Merged.

Note: See TracTickets for help on using tickets.