Opened 6 years ago

Closed 6 years ago

#8268 closed defect (not a bug)

Pidgin / Tor - - - Rejecting SOCKS request for anonymous connection to private address

Reported by: 45millions Owned by:
Priority: Medium Milestone:
Component: User Experience/Tor Support Version:
Severity: Keywords: Pidgin
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello Tor Team, i use Pidgin and the config is
Proxy-Typ: TOR (Socks5) Host: 127.0.0.1 Port: 9050
always when i start pidgin i became the message
[Warning] Rejecting SOCKS request for anonymous connection to private address [scrubbed].

is that message to be a risk to my anonymity?

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by arma

Component: VidaliaTor Support
Owner: chiiph deleted
Priority: criticalnormal
Status: newassigned

This happens because some instant messaging protocol you're trying to use wanted to connect to an address like 192.168.1.1 or 127.0.0.1. It could be a bug in pidgin, or it could be a bug in the instant messaging service you're trying to use. In any case it is not a Tor bug.

comment:2 Changed 6 years ago by arma

Resolution: not a bug
Status: assignedclosed

I suggest you mail the help@rt address if you have further support questions:
https://www.torproject.org/about/contact

(I see this complaint from Tor every so often when I use AIM with Pidgin over Tor. I haven't figured out if Pidgin has broken proxy support ("maybe it's asking the proxy to connect to the address of the proxy rather than the real destination"), or if one of AOL's servers really is returning the address 127.0.0.1 in response to some DNS request, or what.

Probably the former. It would not be the first, or the last, pidgin bug.

Note: See TracTickets for help on using tickets.