Opened 6 years ago

Closed 2 years ago

#8297 closed defect (fixed)

Do not start reading connection if any blocking reason still present

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: easy, tor-relay
Cc: Actual Points:
Parent ID: Points: medium
Reviewer: Sponsor:

Description

Tor can to start reading edge connection just because received SENDME cell, or cell queue reduced only or just refilled buckets. While all another reasons of blocking connection still present. No need to start reading edge connection if any of blocking reasons still true.

Child Tickets

Attachments (1)

diff.stall (1.5 KB) - added by cypherpunks 6 years ago.
Some simple idea

Download all attachments as: .zip

Change History (21)

Changed 6 years ago by cypherpunks

Attachment: diff.stall added

Some simple idea

comment:1 Changed 6 years ago by cypherpunks

Some simple idea attached

comment:2 Changed 6 years ago by nickm

Status: newneeds_review

That patch looks plausible to me for 0.2.4. Let's test it some and make sure. (We'll need to try it on an exit or a busy client, I think.)

Do we expect a performance win on this? How should we try to measure it?

For 0.2.5, I'd like to use an approach more like what I described in #8111 . It changes more of the code, but the end result seems less kludgey and less likely to be littered with did-we-really-mean-that functions.

comment:3 Changed 6 years ago by nickm

Keywords: tor-relay added

comment:4 Changed 6 years ago by nickm

Milestone: Tor: 0.2.4.x-finalTor: 0.2.5.x-final

comment:5 Changed 5 years ago by nickm

Milestone: Tor: 0.2.5.x-finalTor: 0.2.6.x-final

tentatively moving these out of 0.2.5.

comment:6 Changed 5 years ago by nickm

Status: needs_reviewneeds_revision

For 0.2.6, let's do the version of this where we turn it into a bitfield.

comment:7 Changed 5 years ago by nickm

Keywords: 026-triaged-1 026-deferrable added

comment:8 Changed 4 years ago by nickm

Milestone: Tor: 0.2.6.x-finalTor: 0.2.7.x-final

comment:9 Changed 4 years ago by nickm

Keywords: 027-triaged-1-out added

Marking triaged-out items from first round of 0.2.7 triage.

comment:10 Changed 4 years ago by nickm

Milestone: Tor: 0.2.7.x-finalTor: 0.2.???

Move *most* 0.2.7-triaged-1-out needs_revision items into 0.2.???. Keep a few based on my sense of the sensible.

comment:11 Changed 3 years ago by nickm

Points: medium
Severity: Normal

comment:12 Changed 2 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:13 Changed 2 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:14 Changed 2 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:15 Changed 2 years ago by nickm

Keywords: 027-triaged-in added

comment:16 Changed 2 years ago by nickm

Keywords: 027-triaged-in removed

comment:17 Changed 2 years ago by nickm

Keywords: 027-triaged-1-out removed

comment:18 Changed 2 years ago by nickm

Keywords: 026-triaged-1 removed

comment:19 Changed 2 years ago by nickm

Keywords: 026-deferrable removed

comment:20 Changed 2 years ago by nickm

Resolution: fixed
Status: needs_revisionclosed

Closing as fixed; remaining part is a duplicate of #8111

Note: See TracTickets for help on using tickets.