Opened 7 years ago

Closed 6 years ago

#8302 closed defect (fixed)

Various aspects of Tor Browser branding broken for some builds

Reported by: mikeperry Owned by: erinn
Priority: Very High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-rebase-regression, tbb-usability
Cc: brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Non-English builds of Tor Browser still say "Mozilla Firefox" on their titlebar and on certain other UI elements. Thankfully on MacOS, the dock icon is still ours, and the menu bar still says "TorBrowser", as does Command-Tab and the Dock tooltip text.

At a wild guess, my bet is that they moved the titlebar string and probably some other stuff into property files in their langpack XPIs. We probably need another Makefile hack to replace them.

The right way to fix this is #8219, but I think a Makefile hack might be more expedient at this point? Especially since #8219 might conflict with Tails' branding extension.

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by mikeperry

Summary: Some aspects of Tor Browser branding broken for localized buildsVarious aspects of Tor Browser branding broken for some builds

Here's what we know so far:

  1. All branding is broken for TBB-stable on Linux
  2. All branding is broken for non-English TBB-alpha on Linux (en-US was fine as of last week)
  3. Some non-English branding strings are broken on TBB-stable on Mac (icons and tooltips are fine)

I have no idea about Windows.

I suspect this is related to Makefile changes we had to do for localized property strings in #3944. Unfortunately each of (English, Non-English) x (Windows, Mac, Linux) x (TBB-Alpha, TBB-Stable) have distinct (but copy+pasted) Makefile commands. Maybe we should export those copy+pasted commands to a single script.

comment:2 Changed 6 years ago by mikeperry

Keywords: tbb-rebase-regression tbb-usability added

comment:3 Changed 6 years ago by erinn

It looks like more of the branding is handled within the langpack XPIs now. I was able to "fix" this on my local bundles by merely editing and re-zipping one, but I'm working on figuring out the best way to do that per-bundle. Some of our own changes either get inherited or reset stuff that is inside the langpacks (e.g., our browserconfig.properties is correct), but looking at the way some of the other files are structured and localized (brand.dtd, brand.properties, the two main files that need fixin').

We don't currently create a brand.dtd or brand.properties on a per-language basis except for en-US. Those files are correct which is why the en-US bundle is not broken. Assuming post-process shell script madness on XPIs is too icky and prone to breakage, a possible solution would be to try either creating a canonical brand.dtd and brand.properties that is inherited by all languages (as browserconfig.properties is) or creating per-language branding directories. I'm not sure if either will work; the former because I don't know if Firefox can/will inherit like that, the latter because I'm not sure the language stuff gets built in without building a targetted language Firefox.

More investigation required. Will report back if I find anything new or interesting.

comment:4 Changed 6 years ago by brade

Cc: brade added

comment:5 Changed 6 years ago by mikeperry

Resolution: fixed
Status: newclosed

This should be fixed in TBB-2.3.25-5.

Note: See TracTickets for help on using tickets.