Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8324 closed defect (fixed)

Tor Browser 2.3.25-4 crashes with Drag and Drop on Windows

Reported by: cypherpunks Owned by: mikeperry
Priority: Very High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-rebase-regression, MikePerry201303
Cc: nvivek@…, ieatspam2000-torbugs@…, g.koppen@… Actual Points: 6
Parent ID: Points:
Reviewer: Sponsor:

Description

In the past 24 hours my browser crashed like 30-40 times. This wasn't the case with the previous versions.

Heavy webpages and loading too many tabs of them was always freezing my browser but I don't think that they were crashing it. Since 2.3.25-4 it brings my browser closer to crashing but that's not the only cause. For example, when I drag & drop a html or txt file to Tor Browser it mostly crashes. And I use the middle click scrolling too much and that's another trigger for crashing.

My OS: Windows 7 64 bit

Child Tickets

Attachments (2)

torbutton-1.5.1pre.xpi (859.8 KB) - added by mikeperry 7 years ago.
Torbutton test XPI to Block Drag+Drop on Windows
firefox-debug_0104_2013-02-27_23-54-32-562.log (66.1 KB) - added by mo 7 years ago.

Download all attachments as: .zip

Change History (29)

comment:1 Changed 7 years ago by cypherpunks

Lol, right after I posted this ticket. I tried to close another tab from the browser and bam! it crashed again.

By the way, I think my graphic card or ram could be one of the causes of crashing

comment:2 Changed 7 years ago by cypherpunks

I made some tests to understand where the problem comes from. The easiest way to crash my browser is draggin&dropping a file onto the browser. I'm using very little text files for this.

I installed a fresh Tor Browser to see if my additional extension or something was the reason but this one crashed too.

Then I thought maybe the new Firefox version 17.0.3 was the reason. Downloaded and installed a fresh Firefox and tried the same drag&drops and some surfing on the web but nothing happened at all.

So I'm sure there are problems with the patches or extensions on the latest Tor Browser

comment:3 Changed 7 years ago by cypherpunks

Priority: majorcritical

Thanks for not helping

comment:4 Changed 7 years ago by mikeperry

Keywords: tbb-rebase-regression MikePerry201303 added
Summary: Tor Browser 2.3.25-4 crashing too frequentlyTor Browser 2.3.25-4 crashes with Drag and Drop on Windows

Did it occur to you that maybe this doesn't happen anywhere else but Windows? Possibly even only your specific Windows version? Or that I might have been prepping a Windows 7 VM so I can actually start (re)bulding TBB to rule out patches, but it takes a while to get a build image set up? Or that I might also be organizing and tagging the 10 or so rather serious *other* bugs that people are complaining about?

Either way, thanks for being a jerk. You just won yourself an all-expenses-paid ticket into next month. See you Friday.

comment:5 Changed 7 years ago by VNI

FYI I am seeing the same problem on Windows XP Service Pack 3. Thanks.

comment:6 Changed 7 years ago by VNI

Cc: nvivek@… added

comment:7 Changed 7 years ago by VNI

Cc: nvivek@… removed

comment:8 Changed 7 years ago by VNI

Cc: nvivek@… added

comment:9 Changed 7 years ago by HiMyNameIsBob

I can confirm this. Happens every time I drag and drop a link into TorBrowser. This didn't occur in 2.3.25-2.

I'm running Windows 8 (64bit).

comment:10 Changed 7 years ago by HiMyNameIsBob

Cc: ieatspam2000-torbugs@… added

comment:11 Changed 7 years ago by mo

I can reproduce this on a mostly clean Windows XP 32bit VM. Tor Browser crashes on every attempt to drag and drop a file onto it. It just closes, no entries in the Windows Event Log.

It does NOT crash when I run tbb-firefox.exe directly, creating a new user profile -- which suddenly is possible again. I have reopened #4192.

comment:12 Changed 7 years ago by mo

Some more information: This is not extension related. It crashes even with all extensions (NoScript, HTTPS-E, TorButton) disabled.

WinDbg:

a5c.5e0): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00000000 ebx=0012a4e8 ecx=050e5690 edx=00000000 esi=05a74600 edi=ffffff87
eip=01fc6c65 esp=0012a388 ebp=0012a3b4 iopl=0 nv up ei pl zr na pe nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010246
* ERROR: Symbol file could not be found. Defaulted to export symbols for E:\Tor Browser\FirefoxPortable\App\Firefox\xul.dll -
xul!JSD_GetValueForObject+0xdd5a5:
01fc6c65 8b00 mov eax,dword ptr [eax] ds:0023:00000000=????????

Changed 7 years ago by mikeperry

Attachment: torbutton-1.5.1pre.xpi added

Torbutton test XPI to Block Drag+Drop on Windows

comment:13 Changed 7 years ago by mikeperry

mo: Thanks for more details. I've attached an XPI that should entirely disable all dragging on Windows. Can you let me know if it stops the crash after you install it? If you can somehow launch TBB with debugging (on linux, it's --debug), there should also be some additional associated Torbutton logs that might be helpful if it still does crash.

A real solution will be to fix the root issue with a Firefox patch, but I am having a hard time getting a working Windows build VM that can even build Firefox.

comment:14 Changed 7 years ago by mo

Sorry, but it does not change a thing. --debug doesn't do anything either on Windows.

I have attached a logfile from a WinDbg session created following the documentation at https://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg .

comment:15 Changed 7 years ago by mikeperry

Well, this is going to have to wait for me to get a working Windows build VM then. Unfortunately, my first try using https://gitweb.torproject.org/torbrowser.git/blob/master:/docs/buildmachine_setups/windows.txt on an x86 VM I had laying around led to a machine that crashed during the Firefox build... I'm going to try again once I get my hands on 64bit media.

So this may be a while. A Friday start date for working on a real fix might have been a bit optimistic, at this rate :/.

If anyone is able to use those instructions to produce a working build machine, you could try eliminating Firefox patches and seeing what happens. My first guess is that this is the culprit: https://gitweb.torproject.org/torbrowser.git/blob/maint-2.4:/src/current-patches/firefox/0018-Adapt-Steven-Michaud-s-Mac-crashfix-patch.patch but who knows.

comment:16 Changed 7 years ago by mikeperry

Oh also: that WinDBG log is unfortunately not fully clear, since we strip symbols and build non-debug, optimized builds. It definitely looks like a NULL pointer dereference somewhere, but exactly where or why is not clear from it.

comment:17 Changed 7 years ago by gk

Cc: g.koppen@… added

I just built a Firefox with the TorBrowser patches applied (but NOT patch 7) in a Win7 VM and only get the browser crashed if I install Torbutton 1.5.0 additionally. I'll start eliminating patches in ca 3 hours (don't have time earlier) beginning with patch 18 if nobody is faster.

comment:18 Changed 7 years ago by gk

Removing patch 18 disables the drag and drop entirely with Torbutton >= 1.4.5. Thus no easy way to know whether it is the cause of the crash. Looking at comment 17 Torbutton is at least involved in it.

comment:19 Changed 7 years ago by mikeperry

Thanks for this testing GK. Yesterday I rewrote the drag and drop hooks as an observer as I said on IRC. It works on Linux, so I went ahead and pushed the patch changes to torbrowser.git and the torbutton changes to torbutton.git. I haven't yet tested on Windows... If anyone could check that out,

comment:20 Changed 7 years ago by helpinghand

Same here. I run the latest tor browser bundle on Windows 7 (64bit) and whenever I drag n drop links from my local drive to the firefox (tbb) browser it crashes and all components within torbundle are shut down forthwith. That's really strange because I have never experienced any difficulty related to it with the previous releases. I'm certain it must be a bug through binary changes? Whatever is triggering this issue a fix is needed here. I cannot continue to work under these bad conditions and have to stay with the old tor bundle.

comment:21 Changed 7 years ago by mikeperry

Status: newneeds_review

comment:22 Changed 7 years ago by gk

Drag and drop are working and the browser is not crashing anymore. The overall approach looks good to me as well. Not sure if that qualifies as a review. If have not had time to look at the code in detail yet, though, but would not mind doing that if you want, Mike.

comment:23 Changed 7 years ago by helpinghand

I can't confirm! The drag & drag issue still occurs to me constantly. I cannot see what changes have been made so far. A detailed explanation is required here. Would somebody please attend to the matter? I'd really appreciate. thx

comment:24 Changed 7 years ago by cypherpunks

as the original reporter I want to add:

drag&drop isn't the only reason to crash, the browser is crashing frequently in every case, I lost many of my work on these hundreds of crashes

it is also frequently crashing my GPU, while other browsers never crashed

comment:25 Changed 7 years ago by cypherpunks

Oh, I just saw the new version for the browser.

I will update this ticket if the crashing problems remain

comment:26 Changed 7 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

This should be fixed for Drag and Drop in TBB 2.3.25-5. Other crashes when you're not dragging anything should be filed separately. See also #8337.

comment:27 Changed 7 years ago by mikeperry

Actual Points: 6
Note: See TracTickets for help on using tickets.