Opened 7 years ago

Closed 7 years ago

#8340 closed defect (fixed)

No video on Tweakers

Reported by: Dr_IT Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This site https://tweakers.net/video/ shows no video since a short time. Could it have something to do with content.tweakers.tv in the background?

I am using https-everywhere-3.1.3 on firefox.

Can this ruleset please be fixed?

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by pde

Keywords: httpse-ruleset-bug added

comment:2 Changed 7 years ago by mikkoharhanen

Resolution: fixed
Status: newclosed

comment:3 in reply to:  2 Changed 7 years ago by mikkoharhanen

Sorry, just noticed a missing slash. The correct commit is this:
https://github.com/mikkoharhanen/https-everywhere/commit/006a0a5c77b5c91869db92fc18aa4823bcf7e4c3

comment:4 Changed 7 years ago by Dr_IT

Resolution: fixed
Status: closedreopened

The solution does not seem to have worked. I checked the XML source to confirm i had the new version with the crossdomain exclusion and it was. Still no video. After disabling whole tweakers.net rule, it gives video...

comment:5 Changed 7 years ago by schoen

Maybe one of you is using the Flash player and the other is using the HTML5 player?

comment:6 Changed 7 years ago by mikkoharhanen

Could you give me a link to a broken video so I could test more? I watched dozens of videos with Firefox and Chrome and could not reproduce the problem.

Is it possible that you are not yet using the updated ruleset? This fix has not been released yet so only way to get it is to either compile from HTTPS-E master source or to manually copy the XML file to Firefox's profile. If you click 'View XML Source' from 'Enable/Disable Rules' menu, HTTPS-E will show the ruleset from the master repository and not the ruleset the extension is currently using.

If you click the link http://tweakers.net/crossdomain.xml, is it redirected to HTTPS? The updated rule should not change that URL.

comment:7 Changed 7 years ago by Dr_IT

Resolution: fixed
Status: reopenedclosed

I'm sorry, i thought by "View XML Source" it would show the current active rule.
I copied manually the new xml file and it does work. Thank you very much!

Note: See TracTickets for help on using tickets.