Opened 7 years ago

Closed 7 years ago

#8347 closed defect (worksforme)

Webfonts blocked in TBB w/ FF 17

Reported by: abel Owned by: mikeperry
Priority: Medium Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords: tbb-usability-website
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

github.com uses a unicode characters as icons from a custom webfont they load. In the latest TBB alphas this font is not being loaded, and as such, the icons are displayed in the default font, which makes the site very difficult to use.

Attached is an annotated screenshot.

I tested this with NoScript and HTTPS-E disabled, so I believe it relates to the FF patch set.

Child Tickets

Attachments (1)

github.png (50.6 KB) - added by abel 7 years ago.
example of github's broken icon font

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by abel

Attachment: github.png added

example of github's broken icon font

comment:1 Changed 7 years ago by mikeperry

Keywords: tbb-usability-website added

All of these fonts look fine to me with TBB-2.3.25-4 on Linux. Are you using the official TBB? What platform? Note that the Tails FF17 build (and any other third party builds) may still be using an older version of the font patch that doesn't exempt these fonts from blocking.

comment:2 Changed 7 years ago by abel

This is using TBB 2.4.9-alpha-1 on Linux x86_64

comment:3 Changed 7 years ago by abel

I upgraded to the latest alpha (2.4.10-alpha-2) and now the fonts appears to be working.

Sorry, didn't realize I a new alpha had been released. You can close if you wish.

comment:4 Changed 7 years ago by mikeperry

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.