Opened 7 years ago

Closed 7 years ago

#8349 closed defect (fixed)

CSS and images on sourceforge.jp are not loaded properly

Reported by: moritasho Owned by: schoen
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

I noticed a breakage in sourceforge.jp with the rule "SourceForge (partial)". It seems that CSS and images on the site are not loaded properly.

For example, accessing to an file

http://static.sourceforge.jp/css/sfx.net.css?t=1326353084

will be redirected to

https://static.sourceforge.net/css/sfx.net.css?t=1326353084

But the file does not exist.
I think it should be redirected to

https://static.sourceforge.jp/css/sfx.net.css?t=1326353084

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by schoen

Owner: changed from pde to schoen
Status: newaccepted

This is true. Thanks! We should try to find out if there's any reason to redirect any of the sourceforge.jp URLs to sourceforge.net in the first place.

comment:2 Changed 7 years ago by schoen

Resolution: fixed
Status: acceptedclosed

OK, I split out the sourceforge.jp redirections. Currently only (www.)?sourceforge.jp and static.sourceforge.jp will try to redirect, and they will redirect to the sourceforge.jp version instead of the sourceforge.net version. This seems to fix the problem. I wish there were more HTTPS coverage on these sites (especially for the software uploads and downloads!!).

Note: See TracTickets for help on using tickets.