Opened 6 years ago

Closed 4 years ago

#8352 closed enhancement (fixed)

TBB with Firefox 17 ESR is exhibiting slow, clunky UI performance

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-rebase-regression, needs-triage
Cc: mcs, intrigeri@… Actual Points:
Parent ID: #8401 Points:
Reviewer: Sponsor:

Description

TBB with Firefox 17 ESR is exhibiting slow and clunky UI performance. The previous TBB with Firefox 10.xx was not this sluggish.

It is noticeable especially when opening multiple tabs, closing tabs, opening preferences, dragging tabs etc. i.e. general UI performance.

Hardware specifications that this behavior was tested on:

Debian 6.0.7 (squeeze)
32-bit
Intel CPU Core 2 Duo 2.1 Ghzx2
2 GB RAM

TBB version: tor-browser-gnu-linux-i686-2.3.25-4-dev-en-US

Child Tickets

Change History (17)

comment:1 Changed 6 years ago by cypherpunks

Type: defectenhancement

Nobody has anything to say about this?

comment:2 Changed 6 years ago by nickm

Component: - Select a componentTorBrowserButton
Owner: set to mikeperry

Please be patient, if you can. There are almost 300 open bundle/browser tickets at the moment, and only a small number of developers working on them.

Do you have the same issues running other versions of the bundle? Running stick firefox not from Tor? etc

comment:3 Changed 6 years ago by arma

My suggestion would be to turn parts of it off and see if performance improves.

E.g., the https everywhere extension, or the TorBrowserButton extension, etc.

You're going to have to partly debug this one on your own, since it clearly doesn't happen to Mike and he's the best one to fix it.

comment:4 Changed 6 years ago by mikeperry

Component: TorBrowserButtonTor bundles/installation
Keywords: tbb-rebase-regression added
Owner: changed from mikeperry to erinn

This might actually be due to the --disable-optimize build flag that we had to start using in FF17. The vanilla Firefox source crashes gcc/ld on Debian 6.0 32bit with --enable-optimize, so we had to turn it off. Interestingly, Ubuntu was able to build Firefox with --enable-optimize without crashing, as was Debian x64's. Seemed like a toolchain bug that debian hasn't backported the fix for?

We need to either ditch Debian as our build platform, or tell them to figure out what is wrong with their toolchain.

#8156 is another similar odd issue caused specifically by our Debian x86 build flags/build setup. Very weird stuff.

comment:5 Changed 6 years ago by cypherpunks

Sorry Mike, didn't mean to be rude.

I don't have a x64 Debian system to try it out on, unfortunately.

I did try Firefox 17 ESR vanilla (non-TBB version) on 32-bit Debian (same system I noticed the problem) and it is pretty smooth; this problem doesn't exhibit itself.

@arma: I guess since it's been identified that the problem is due to the --disable-optimize flag, I am not going to try to debug by removing/adding individual addons.

comment:6 in reply to:  5 Changed 6 years ago by mcs

Cc: mcs added

Replying to cypherpunks:

I did try Firefox 17 ESR vanilla (non-TBB version) on 32-bit Debian (same system I noticed the problem) and it is pretty smooth; this problem doesn't exhibit itself.

I don't have experience building Firefox on a wide variety of Linux systems, but my past experience in trying to support various Firefox extensions is that obscure bugs often show up in non-Mozilla Linux builds. These are more than likely toolchain-related... so it might be wise to duplicate the build environment that Mozilla uses for their official builds as much as possible. I am not sure where to obtain all of the details though.

comment:7 Changed 6 years ago by cypherpunks

Hi, original poster here.

Is there something I can do to help resolve this?

Like, contacting someone at Debian, maybe?

comment:8 Changed 6 years ago by mikeperry

Thanks for offering. The first thing would be to contact the Debian Iceweasel maintainer and ask them how they build it for x86 on Debian 6.0.6. When I tried building the vanilla Firefox source with no patches directly from https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/17.0.3esr/, I still had to use --disable-optimize or the build itself would crash.

Presumably this means the Iceweasel people have to have hit the problem, too. If they also just disabled optimization and have no idea why it crashes, the next step would be contacting the Debian gcc maintainer and asking them to reproduce the crash and see what is going on.

comment:9 Changed 6 years ago by mikeperry

You can also of course test Iceweasel and see if it exhibits any noticable performance problems. about:buildconfig will also give you details about how iceweasel was built (I don't have my debian VM in front of me).

comment:10 Changed 6 years ago by mikeperry

Parent ID: #8401

comment:11 in reply to:  8 Changed 6 years ago by intrigeri

Cc: intrigeri@… added

Replying to mikeperry:

The first thing would be to contact the Debian Iceweasel maintainer and ask them how they build it for x86 on Debian 6.0.6.

At Tails, we build our "Iceweasel 17 + Torbrowser patches" web browser with the unmodified debian/rules from Iceweasel.

Debian's repository: git://git.debian.org/git/pkg-mozilla/iceweasel.git

Tails' repository: git://labs.riseup.net/tails_iceweasel.git (see tails/squeeze and tails/master branches).

We simply build using pbuilder in a Squeeze + backports i386 chroot (the underlying kernel is 64-bit, in case it matters, but the toolchain is entirely Squeeze + necessary backports).

I could provide a build log if it may help.

comment:12 Changed 6 years ago by cypherpunks

Try to toggle gfx.xrender.enabled and restart browser, then check it was toggled actually.

comment:13 Changed 4 years ago by erinn

Keywords: needs-triage added

comment:14 Changed 4 years ago by erinn

Component: Tor bundles/installationTor Browser
Owner: changed from erinn to tbb-team

comment:15 Changed 4 years ago by arma

Does Tor Browser still build with --disable-optimize ?

If so, is there a ticket for fixing that?

comment:16 in reply to:  15 ; Changed 4 years ago by mcs

Replying to arma:

Does Tor Browser still build with --disable-optimize ?

If so, is there a ticket for fixing that?

I am pretty sure that we now build with --enable-optimize. See:
https://gitweb.torproject.org/tor-browser.git/blob/refs/heads/tor-browser-24.7.0esr-3.x-1:/.mozconfig

Should we close this?

(also, I marked #8927 as a duplicate)

comment:17 in reply to:  16 Changed 4 years ago by gk

Resolution: fixed
Status: newclosed

Replying to mcs:

Replying to arma:

Does Tor Browser still build with --disable-optimize ?

If so, is there a ticket for fixing that?

I am pretty sure that we now build with --enable-optimize. See:
https://gitweb.torproject.org/tor-browser.git/blob/refs/heads/tor-browser-24.7.0esr-3.x-1:/.mozconfig

Should we close this?

(also, I marked #8927 as a duplicate)

Yes. This is fixed with switching to --enable-optimize again, I think.

Note: See TracTickets for help on using tickets.