Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8357 closed defect (not a bug)

My node is an exit, but consensus says it's not

Reported by: Spider.007 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.3.25
Severity: Keywords: exit flag policy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For a few months my server has been configured to be an exit-node, but never received an exit-flag. I assumed this was because of some bug; but I just noticed I actually am being used as an exit node. This seems odd, I assumed I would only receive exit-traffic once I have an exit-flag?

So: why don't I have an exit-flag and why do I receive exit-traffic anyway?

The node: https://atlas.torproject.org/#details/8DE5D6A67DD16A9C6EABB7EFC69BB81B6E26FCB6

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by karsten

Resolution: not a bug
Status: newclosed

"A router is called an 'Exit' iff it allows exits to at least two of the ports 80, 443, and 6667 and allows exits to at least one /8 address space." See: https://gitweb.torproject.org/torspec.git/blob/HEAD:/dir-spec.txt#l1667

comment:2 Changed 7 years ago by arma

(The Exit flag is used for load balancing, but it doesn't dictate whether you will allow exits, or whether clients will be willing to exit from you.)

Note: See TracTickets for help on using tickets.