Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8362 closed defect (not a bug)

Unable to run two instances of TBB 2.3.25-4 at the same time

Reported by: runa Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am unable to run two instances of TBB 2.3.25-4 at the same time (Debian 64-bit, one TBB in ~/tor, another in ~/tortmp). When I try to start the second instance, I get the following message: Vidalia has connected to a running Tor process that requires a password. Please enter your control password.

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by runa

Resolution: not a bug
Status: newclosed

Found "Set the Tor SOCKS+Control ports to 9150, 9151 respectively on all platforms" in a blog post, so this is not a bug.

comment:2 Changed 7 years ago by arma

Right. Mike found it too tough, at least for now, to teach Torbutton to figure out what port it should be having Firefox use.

You should in theory maybe be able to resume using the random ports by selecting that from Vidalia's Advanced window. But if Mike couldn't teach Torbutton to learn the port, maybe asking Vidalia to randomize the port would break things. Somebody should ask Mike.

Note: See TracTickets for help on using tickets.