Opened 6 years ago

Closed 13 months ago

#8378 closed defect (wontfix)

Windows TBB Firefox breaks when Valida calls Tor *not* as ./tor.exe

Reported by: cypherpunks Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

RE: TBB v2.3.25-4 on Windows 7

I just configured Vidalia to use the Tor within TBB dir as C:\Users\USERNAME\Desktop\Tor Browser\App\tor.exe, but when I start TBB Firefox can't connect to Internet. Then I tried the default .\tor.exe (which is the same exact location as C:\Users\USERNAME\Desktop\Tor Browser\App\tor.exe) and TBB can access Internet no problem.

So, it seems like there are some bugs with using a Tor located anywhere other than .\tor.exe, *and* using C:\Users\USERNAME\Desktop\Tor Browser\App\tor.exe instead of .\tor.exe prevents Firefox from getting online.

This ticket is related to #8367 https://trac.torproject.org/projects/tor/ticket/8376

I made this ticket major priority because as is I can no longer use Tor alpha with TBB. The Tor team doesn't build alpha versions of TBB for Windows users, unlike they do for their more favorite OSes :( So, if this isn't fixed it appears Windows users are placed further back into the closest, being we can't even use (nor test for bugs with TBB) a Tor alpha build.

Please fix this, and please don't take many months to do so. I understand you're all overworked, and you all are doing you best, however, it does seem Windows problems are normally lower priority than problems with other OSes.

Child Tickets

Attachments (3)

Proxy server refusing connection.jpg (199.1 KB) - added by cypherpunks 6 years ago.
Proxy Error
TBBv2.3.25-2_no_proxy_error.jpg (371.4 KB) - added by cypherpunks 6 years ago.
TBBv2.3.25-4_proxy_error.jpg (333.1 KB) - added by cypherpunks 6 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 Changed 6 years ago by cypherpunks

Oh yea, the problem is not a space in dir structure, i.e., \Tor Browser\, because using \Tor_Browser\ give the same exact result as \Tor Browser\.

comment:2 Changed 6 years ago by cypherpunks

Well, if I drop tor.exe (from v0.2.4.10-alpha-win32-1) into \Tor Browser\App\, overwriting the stable version of Tor included in TBB I can access the Internet again.

What issues arise by copying the alpha Tor over the stable Tor, in TBB?

comment:3 Changed 6 years ago by mo

Priority: majornormal

Yes, you can copy the alpha tor.exe there without any side effects. Lowering priority to "normal".

comment:4 Changed 6 years ago by mo

Component: Tor bundles/installationVidalia
Owner: changed from erinn to chiiph

comment:5 Changed 6 years ago by cypherpunks

Thanks mo

comment:6 Changed 6 years ago by cypherpunks

However, mo, I'm not sure this is a Vadalia issue:

The version of Vadalia hasn't increased between TBB v2.3.25-2 and v2.3.25-4. Yet, Firefox can connect to the Internet from TBB v2.3.25-2 using installed Tor alpha (e.g., v0.2.4.10-alpha-win32-1) in \PROG FILES (x86)\ via Vadalia v0.2.21.

However, if I try the same as above, with TBB v2.3.25-4 and Tor alpha v0.2.4.10-alpha-win32-1, Firefox times-out and cannot connect to the Internet.

Is this maybe an issue with updating Firefox from v10 to v17.0.3esr? That's what I think may be the issue, now that I know the previous version of TBB works just fine with current alpha Tor installed into \PROG FILES (x86)\ . . .

I think this should be changed back to TBB ticket for Erinn, but I'll defer to her, Chipph and you.

Thanks

comment:7 Changed 6 years ago by cypherpunks

Or, this could be due to updates to TorButton by Mike; IIRC this current TBB version includes a TorButton with a lot of code updates. Hmmm.

comment:8 Changed 6 years ago by mo

So you DO point to another tor that uses a different torrc? I thought you were just editing the tor.exe location to point to the same file, one time with absolute path and one time with relative path.

The latest release moved from SOCKS port 9050 to 9150. Compare the two torrc files. In general, always use the Tor(rc) that comes with the latest bundle, and incorporate your own changes carefully. Usually, you can safely replace the tor.exe inside the bundle directory, because the directives Tor Browser Bundle uses don't change too often.

Changed 6 years ago by cypherpunks

Proxy Error

comment:9 Changed 6 years ago by cypherpunks

Hi Mo,

Yes, the installed alpha Tor uses it's own torrc, if Vadalia is pointed to e.g. \PROG FILES (x86)\Tor\tor.exe.

I think you nailed it, re the problem I think is SOCKS. However, shouldn't the newest Tor alpha (v0.2.4.10-alpha-win32-1) use the new SOCKS 9150 just like the new TBB? I'll check that right now.

comment:10 Changed 6 years ago by mo

Resolution: not a bug
Status: newclosed

Tor uses whatever SOCKS port is defined in their torrc. Only the latest TBBs configure it to use 9150 instead of 9050.

Changed 6 years ago by cypherpunks

Changed 6 years ago by cypherpunks

comment:11 Changed 6 years ago by cypherpunks

Hi Mo,

When installing alpha Tor's, for use by Vadalia within TBB, I have never had to edit the alpha Tor's torrc. The installed (alpha) Tor uses the torrc of the (stable) Tor found in TBB (see attached screenshots above).

When I start a fresh Tor alpha v0.2.4.1 (without editing its torrc) with TBB v2.3.25-2, Firefox can get online (SOCKS 9050). However, when I start a fresh Tor alpha v0.2.4.1 (without editing its torrc) with TBB v2.3.25-4 Firefox cannot get online due to proxy error. In both cases, the alpha Tor is using the torrc of that TBB version. TBB v2.3.25-2 works and TBB v2.3.25-4 does not; the latter has proxy error even though alpha (installed) Tor is using the torrc within that TBB.

Regrading SOCKS: TBB v2.3.25-4 is using 9050 according to torrc, which is used by vadalia.conf. The original torrc, renamed to torrc.orig.1 by Vadalia, lists SOCKS 9150. That's odd, no?

comment:12 Changed 6 years ago by cypherpunks

Resolution: not a bug
Status: closedreopened

comment:13 Changed 6 years ago by cypherpunks

Reoped because this is a bug. See my message above.

comment:14 Changed 6 years ago by cypherpunks

It seems Vadalia is editing the original torrc SOCKS from 9150 to 9050 when Vadlia creates torrc and renames original to torrc.orig.1.

comment:15 Changed 6 years ago by cypherpunks

And besides, the SOCKS bug I just found isn't even the bug I started this report for - at least it doesn't seem so to me. It seems the SOCKS bug and calling Tor by Vadalia from anything other than ./tor.exe bug are two separate bugs. What do you think?

comment:16 in reply to:  15 ; Changed 6 years ago by mo

Again, if you point to a tor.exe in a different bundle, it will use the other bundle's torrc (and likely get confused over it). This is not what you want.

I still don't fully understand what you're after. There is a new alpha bundle, 2.4.10-alpha-2, that brings the same Tor Browser as 2.3.25-4. If you want to use other Tor versions for whatever reason, copy the tor.exe to "App" inside the bundle you want to use.

If you want to do more experiments, start over with newly extracted bundles. Looks like you did change stuff, otherwise there would not be any torrc.orig.1.

Your original report describes exactly this: Tor Browser is configured to use a different port than the tor.exe/torrc pair you point Vidalia at. Not a bug.

comment:17 Changed 6 years ago by cypherpunks

This bug seems like it goes back to Tor alpha and its SOCKS port. Editing SOCK manually to 9150 in the new torrc works as it should.

So what's the issue here? Alpha Tor (v0.2.4.1) using SOCKS 9050 and Vadalia (within TBB v2.3.25-4) reading that SOCKS from Tor (as I don't see a torrc for installed alpha Tor anywhere), then Vadalia overwriting TBB's torrc with the new one generated from the alpha Tor? If so, it seems the problem is with alpha Tor's default SOCKS port.

In any case, I've done about as much I can do (time and skill wise) to help track down this issue. I'll shut-up now. Thanks much mo!

comment:18 in reply to:  16 ; Changed 6 years ago by cypherpunks

Replying to mo:

I still don't fully understand what you're after. There is a new alpha bundle, 2.4.10-alpha-2, that brings the same Tor Browser as 2.3.25-4. If you want to use other Tor versions for whatever reason, copy the tor.exe to "App" inside the bundle you want to use.

I want to run alpha Tor with TBB. How I do that is the open question. I prefer to install Tor, and run it from its install location with Vadalia. That is how I've done it for a long time up until now. The problem as you pointed out is SOCKS change. The most recent Tor alpha v0.2.4.1 hasn't yet been changed in its torrc. That's the problem, which I just figured out.

The best fix is to wait for Tor devs to update Tor alpha torrc to 9150 from 9050. Otherwise it's clunky to copy/paste tor.exe and I'm not so sure it's always going to be safe to do so (re breaking aspects of installed Tor vs. portable Tor). What I'll do until the Tor devs can update the Tor alpha torrc, is I'll manually edit the torrc in TBB from 9050 to 9150.

If you want to do more experiments, start over with newly extracted bundles. Looks like you did change stuff, otherwise there would not be any torrc.orig.1.

The torrc.orig.1 is created when you choose a different Tor via. Vadalia. If you use the Tor in TBB then there's only torrc, not torrc.orig.1.

I always start with fresh bundles. There is a bug here, I just think you're not seeing it - the bug is Tor alpha default torrc hasn't been updated to reflect the updated SOCKS in TBB. I think it would be wise to use the same SOCKS for Tor and TBB, as Tor Project moves forward, rather than SOCKS 9050 for installed Tors and SOCKS 9150 for Tors found in TBB.

Your original report describes exactly this: Tor Browser is configured to use a different port than the tor.exe/torrc pair you point Vidalia at. Not a bug.

I don't agree. We'll wait for others to chime in. See my comments above. This report has taken the long way to get to where it needs to go, granted, but there's is a bug here. See above.

comment:19 in reply to:  18 Changed 6 years ago by cypherpunks

Replying to cypherpunks:

And besides, the SOCKS bug I just found isn't even the bug I started this report for - at least it doesn't seem so to me. It seems the SOCKS bug and calling Tor by Vadalia from anything other than ./tor.exe bug are two separate bugs. What do you think?

Replying to mo:
I still don't fully understand what you're after. There is a new alpha bundle, 2.4.10-alpha-2, that brings the same Tor Browser as 2.3.25-4. If you want to use other Tor versions for whatever reason, copy the tor.exe to "App" inside the bundle you want to use.

There are two potential bugs discussed here:

  1. Using any other location than ./tor.exe in Vadalia causes proxy error in Firefox. Even if it's the full path to the Tor in \Tor Browser\App\ (i.e., the full path to ./tor.exe)
  1. Tor alpha v0.2.4.10-win32-1 torrc is using SOCKS 9050 (secondary issue)

comment:20 Changed 20 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:21 Changed 13 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: reopenedclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.