Opened 7 years ago

Closed 7 years ago

#8385 closed defect (invalid)

[Mac] Tor Browser Can't be Reopened if Sharing

Reported by: Haravikk Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.3.25
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Summary
If installed on a Mac the Mac browser bundle is not able to re-open TorBrowser if Vidalia remains open, which occurs if participating as a relay for the Tor network.

Steps to Setup

  • Install TorBrowser bundle for Mac (fresh)
  • Open TorBrowser-en-US
  • Once Vidalia has opened:
    • Open Settings -> Sharing and choose one of the two relay options, setup as desired.
    • Close TorBrowser
    • Close Vidalia

Steps to Reproduce

  • Open TorBrowser-en-US
  • Once TorBrowser has opened, bring it to focus and quit.
  • Attempt to open TorBrowser-en-US

Expected Results
TorBrowser should reopen, using the already running Vidalia/Tor.

Actual Results
Vidalia remains open while TorBrowser does nothing.

Notes
I'm not sure what the best fix would be be; part of the problem is that the basic Tor setup isn't very Mac-like, and to OS X the TorBrowser-en-US bundle is still running so long as Vidalia remains open.

It might make sense if the bundle were made into an installer; while this is a little more complex for users to pick up and use, it means that Vidalia/Tor and the actual browser can be installed as separate applications. It also means that it may be easier to setup Vidalia to run on system startup so that it's always available (and thus always sharing, if so configured) so that the browser can simply open right away.

This might require some changes to Vidalia, such as an option for on-demand connections if used in client mode (so that it isn't holding a connection open that may not be used at all).

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by Haravikk

Resolution: invalid
Status: newclosed

Actually, scratch the setup steps it doesn't seem to matter if you're sharing or not, I just confused myself somehow.
In any situation if you close the browser but not Vidalia then the browser won't re-open when double-clicking TorBrowser-en-US.

Still I think the same recommendation stands; I think it would be better for TorBrowser to focus on bundling a secured version of FireFox, and require you to still download Vidalia or install it at the same time as a means of accessing Tor. When opened the browser should redirect its

Note: See TracTickets for help on using tickets.