Opened 7 years ago

Closed 6 years ago

#8418 closed defect (not a bug)

Create replacement bwscan server

Reported by: mikeperry Owned by:
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Keywords:
Cc: aagbsn, ioerror Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It appears that someone wiped the Cymru bandwidth VM and didn't replace it with anything. We are down to only 4 bw auths as a result.

Can we spin up a new VM for this? We need at least 1G of memory, and of course significant bw capacity.

I think this VM needs to be paired with urass, but I suppose it could be any of the other dirauths instead.

Child Tickets

Change History (14)

comment:1 Changed 7 years ago by phobos

how much bw does it need?

we have serra available now if needed.

comment:2 Changed 6 years ago by mikeperry

I think it needs at least 10mbit downstream, but we have noticed higher capacity measurements from bw auth servers on better uplinks than residential cable modems.

What type of uplink does serra have? How much RAM does it have?

comment:3 in reply to:  2 Changed 6 years ago by phobos

Replying to mikeperry:

I think it needs at least 10mbit downstream, but we have noticed higher capacity measurements from bw auth servers on better uplinks than residential cable modems.

It's on a 50mb down link.

What type of uplink does serra have? How much RAM does it have?

10 mb uplink. and just login to serra silly, 8 GB.

comment:4 Changed 6 years ago by weasel

Is that what should be running on sewerzowi?

comment:5 Changed 6 years ago by phobos

I'm confused. Is this a bandwidth authority or exit authority? Sewerzowi is the bandwidth authority that replaced the dead bandwidth VM roughly 2 years ago.

comment:6 in reply to:  5 Changed 6 years ago by aagbsn

Replying to phobos:

I'm confused. Is this a bandwidth authority or exit authority? Sewerzowi is the bandwidth authority that replaced the dead bandwidth VM roughly 2 years ago.

This ticket seems to be about BwAuthority. Urras doesn't have one yet.

comment:7 Changed 6 years ago by phobos

why not just use sewerzowi?

comment:8 in reply to:  7 Changed 6 years ago by aagbsn

Replying to phobos:

why not just use sewerzowi?

Isn't Mike's DirAuth already using sewerzowi?

comment:9 Changed 6 years ago by phobos

It's a world-readable webserver. I was unaware we needed a single pair of bwauth to dirauth.

comment:10 Changed 6 years ago by mikeperry

Correct. I am already using sewerzowi. We can't use sewerzowi's results more than once. We can't use serra as it is on the same network as sewerzowi.

The 5th bw authority we added for SponsorF in #1778 was maatuska. We have not added any others since.

The bandwidth authority that was destroyed was a CentOS box running in Cymru's cloud setup. We need a new 5th one to replace it.

comment:11 Changed 6 years ago by phobos

I could setup one in iceland.

comment:12 Changed 6 years ago by hsn

Put it in USA, otherwise i will get crap bw

comment:13 Changed 6 years ago by phobos

I think the answer is someone should run a bwauth as they please somewhere on the Internet. And then point another dirauth at it.

comment:14 Changed 6 years ago by weasel

Resolution: not a bug
Status: newclosed

If this is for an authority on the public tor network then its bw auth should not run on torproject.org infrastructure.

Note: See TracTickets for help on using tickets.