Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8422 closed defect (fixed)

DOM localStorage not cleared on New Identity

Reported by: mikeperry Owned by: mikeperry
Priority: Very High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-rebase-regression, MikePerry201303
Cc: Actual Points: 1
Parent ID: Points:
Reviewer: Sponsor:

Description

http://www.stevesouders.com/blog/2012/09/10/clearing-browser-data/ reveals that despite the documentation on MDC (https://developer.mozilla.org/en/DOM/Storage#Storage_location_and_clearing_the_data), window.localStorage is NOT cleared by the "cookie-changed" observer event. We need to clear it explicitly. Isn't that cute. Another evercookie vector.

Since we enabled DOM storage for FF17, this is a regression, and a pretty bad one at that.

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by mikeperry

Actual Points: 1
Resolution: fixed
Status: newclosed

Pushed a fix to origin/master. Works with that test url.

comment:2 Changed 6 years ago by mikeperry

Keywords: MikePerry201303 added
Note: See TracTickets for help on using tickets.