Opened 7 years ago

Closed 7 years ago

#8508 closed defect (fixed)

Tor clients won't build paths on testing tor network with no guards or exits

Reported by: nickm Owned by:
Priority: High Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.10-alpha
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Starting in 0.2.4.10-alpha, with our changes to the minimal requirements for building circuits, clients never consider themselves to be ready to build paths if they're running on a testing tor network without bandwidth info.

Instead they say:

Mar 18 12:00:21.000 [notice] I learned some more directory information, but not enough to build a circuit: We need more descriptors: we have 8/8, and can only build 0% of likely paths. (We have 0% of guards bw, 100% of midpoint bw, and 0% of exit bw.)

Found with Chutney.

Child Tickets

Change History (10)

comment:1 Changed 7 years ago by nickm

Summary: Tor clients won't build paths if bw weight info isn't in the consensus.Tor clients won't build paths on testing tor network with no guards or exits

Whoops. It's actually about the flags assigned by the authorities. This happens in a testing tor network where nobody gets Guard or Exit.

comment:2 Changed 7 years ago by nickm

Apparently nothing gets "Fast" either, which is apparently at least part of the reason they aren't getting Guard.

comment:3 Changed 7 years ago by nickm

Okay. All the nodes in this testing network are saying that they have 0 measured bandwidth capacity. That's .... odd.

comment:4 in reply to:  3 Changed 7 years ago by nickm

Replying to nickm:

Okay. All the nodes in this testing network are saying that they have 0 measured bandwidth capacity. That's .... odd.

That behavior is apparently present in 0.2.3 as well. But there it doesn't break chutney. Or at least, it didn't break chutney before.

comment:5 Changed 7 years ago by nickm

In 0.2.3, with Chutney, votes included the Fast, Guard, and Exit flags. So the problem seems to be that 0.2.4 is now omitting them in this case.

comment:6 Changed 7 years ago by nickm

The problem is

#define ABSOLUTE_MIN_VALUE_FOR_FAST_FLAG 4096

comment:7 Changed 7 years ago by nickm

Dropping that value to 0 makes chutney+testingtornetwork work again. Possible fixes:

  • Drop it to 0 in TestingTorNetwork with a new config option
  • Alternatively, raise the amount of bandwidth you declare yourself to have measured in TestingTorNetwork if you've not every measured bandwidth.

comment:8 Changed 7 years ago by nickm

Status: newneeds_review

There's a fix in branch "bug8508". The bug was introduced in 317d16de which fixed #8145

comment:9 in reply to:  8 Changed 7 years ago by andrea

Replying to nickm:

There's a fix in branch "bug8508". The bug was introduced in 317d16de which fixed #8145

This fix still didn't add the exit flag; additional fix for that is in my bug8508 branch. I've also fixed a make check-spaces complaint in circuituse.c. This is tested and known to bootstrap correctly with chutney.

comment:10 Changed 7 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Great; merging!

Note: See TracTickets for help on using tickets.