Opened 8 years ago

Closed 8 years ago

#8515 closed enhancement (duplicate)

Add CACert root certificate to TBB

Reported by: mo Owned by: mikeperry
Priority: Low Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We agreed on adding the CACert root to TBB. The smoothest way to do it is add a very simple addon that I 'audited' and modified slightly.

https://github.com/moba/cacert-firefox-plugin

direct link https://github.com/moba/cacert-firefox-plugin/blob/master/cacert-firefox-plugin.xpi

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by rransom

Duplicate of #5734.

comment:2 Changed 8 years ago by gk

Why do you need an (additional) add-on to add a root certificate to the trusted certificates?

comment:3 in reply to:  2 Changed 8 years ago by mo

Resolution: duplicate
Status: newclosed

Replying to gk:

Why do you need an (additional) add-on to add a root certificate to the trusted certificates?

There seems to not be a straightforward way to add a root certificate to the global trusted root store. Also, it would likely require changes of the TBB build process. Basically I pressured Mike to add CACert, and he agreed to add an extension that I had audited. Everything else would probably need more work on Mike's side, and it is not that a high priority for him.

If you find out how to do it better, let us know (or contribute a patch).

I am closing this ticket and will post the addon again to #5734 after I pushed an update that made the addon compatible with mobile Firefoxes.

Note: See TracTickets for help on using tickets.