Opened 7 years ago

Closed 7 years ago

#8523 closed task (invalid)

Should Tor ignore unknown pluggable transports?

Reported by: runa Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: asn, aagbsn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

asn, aagbsn, and runa discussed the new design for bridges.tpo and tried to come up with something easy and user friendly. Users should not have to know which TBB they have, what the real name of the transports are, or which transports they can use with their version of TBB.

runa suggested that bridges.tpo can give out a bridge or two of each type, users enter all bridges into Vidalia/TBB, and Tor silently ignores the ones it does not recognize.

At the moment, Tor will throw a warning if you enter a bridge that it does not recognize, such as obfs4, and will then fail to build new circuits. Is it possible to have Tor ignore unknown pluggable transports? Is doing so a good idea?

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by asn

Resolution: invalid
Status: newclosed

In my test, with a legit obfs2 bridge and a fake obfs4 one, Tor will send a warning about the obfs4 bridge but still connect to the obfs2 bridge. I discussed this with Runa, and it seems that this is indeed the intended behavior.

Closing this ticket for now.

Note: See TracTickets for help on using tickets.