Opened 7 years ago

Closed 7 years ago

#8555 closed defect (duplicate)

Tor Browser bundle restores focus to window when tor restarts

Reported by: hellais Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: erinn, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On Mac OS X 10.8.x (but I have also seen it in previous versions of it), when Tor reconnects the window and space containing the Tor browser bundle will have focus to it restored.

Steps to reproduce:

  • Start TBB
  • Disconnect from the network
  • Go to a space different than the one where TBB is in
  • Wait for Tor to automatically reconnect
  • Focus is restored to the TBB space

I believe this is quite a serious anonymity leak because if you restore your laptop from sleep and are showing something to somebody it will unexpectedly switch to your torbrowser all of a sudden.

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by mikeperry

Resolution: duplicate
Status: newclosed

I have noticed that Vidalia attempts to launch an additional TBB if the network goes idle. Unless someone can prove otherwise, I am assuming this is a Vidalia bug. Duping to #6009.

Note: See TracTickets for help on using tickets.