Opened 7 years ago

Last modified 5 days ago

#8560 reopened defect

100% CPU usage in Tor Browser?

Reported by: mikeperry Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-firefox-patch
Cc: ioerror, aagbsn, g.koppen@…, phw, OmegaPhil@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Jake and Aaron both report occasional 100% CPU usage in Tor Browser, even with Javascript disabled. I've seen the thing randomly use a lot of CPU, but it usually calms down for me after I close the offending tab..

If we can figure out how to reproduce this, we can perhaps start by bisecting either our patches, or addons?

Child Tickets

Change History (24)

comment:1 Changed 7 years ago by gk

Cc: g.koppen@… added

comment:2 Changed 7 years ago by phw

Cc: phw added

I have the same problem on Debian testing. It started with Firefox 17 ESR. For me, there doesn't seem to be an offending tab. After running TBB for a while and it starts using 100%, I can close all tabs except a blank one and the CPU load continues.

I'll see if I can avoid this by selectively disabling plugins.

comment:3 Changed 6 years ago by mikeperry

Does this still happen with the 3.0 alpha series?

comment:4 Changed 6 years ago by mikeperry

Status: newneeds_information

comment:5 in reply to:  3 Changed 6 years ago by tor_que

Status: needs_informationnew

Replying to mikeperry:

Does this still happen with the 3.0 alpha series?

Yes, at least with the 32-bit Linux build.

comment:6 in reply to:  3 ; Changed 6 years ago by phw

Replying to mikeperry:

Does this still happen with the 3.0 alpha series?

The alpha series (64-bit) fixed this for me.

comment:7 in reply to:  6 Changed 6 years ago by phw

Replying to phw:

Replying to mikeperry:

Does this still happen with the 3.0 alpha series?

The alpha series (64-bit) fixed this for me.

Correction: It doesn't seem to be fixed for me. Also, this might be related to #9659.

comment:8 Changed 6 years ago by cypherpunks

it's #9901

comment:9 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:10 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser
Owner: changed from mikeperry to tbb-team

comment:11 Changed 5 years ago by OmegaPhil

Cc: OmegaPhil@… added

comment:12 Changed 5 years ago by s7r

At the yearly cleanig of the garage found an old box which was used at the office for accounting purposes, decided to blow the dust away and give it a use... Found out it won't work with Tor Browser, becasue of the CPU.

Tor Browser 3.6.5 is eating 100% CPU, after few hours of either usage either staying idle (in order to keep socksport open for other torified applications). The configration of the computer is this. An old box, running:
Operating system: Debian Wheezy
i386 arhitecture
CPU is AMD Athlon 2800+ @ 2.083 Ghz, 512KB cache
RAM: 1 GB
Data width: 32bit system
---
Continiously monitoring with htop, Tor Browser starts just fine and uses about 18% to 22% CPU. If visiting javascript websites which require the computer some work to do, CPU usage grows accordingly but it does not freeze the computer and gets back to normal value when closing the respective tab. This is for the first 2 or 3 hours.

After some time (2-3 hours) regardless if there are any tabs open or not Tor browser starts to eat 100% CPU until you can't do anything, have to hard reboot. The process name showing 100% in htop is called firefox (from tor browser) and it is shown in 2 instances, one eating 68% and another one with 21 - 25% something like this.

comment:13 in reply to:  12 Changed 5 years ago by cypherpunks

Replying to s7r:

Operating system: Debian Wheezy
i386 arhitecture
CPU is AMD Athlon 2800+ @ 2.083 Ghz, 512KB cache
RAM: 1 GB
Data width: 32bit system
---

What desktop environment?

comment:14 in reply to:  12 Changed 5 years ago by cypherpunks

Replying to s7r:

after few hours of either usage either staying idle

What about system suspend while browser used?

comment:15 Changed 5 years ago by s7r

Desktop environmenet is LXDE with filemanager PCMANFM 1.1
After it reaches the 100% CPU usage, computer becomes inoperative. Can't suspend/logout Can't access anything nor open terminal nor type anything. Hard reboot is the only solution.

comment:16 Changed 5 years ago by cypherpunks

What memory usage reported for firefox on hang?
What video card? What drivers, proprietary?

comment:17 in reply to:  12 ; Changed 5 years ago by cypherpunks

Replying to s7r:

At the yearly cleanig of the garage found an old box which was used at the office for accounting purposes, decided to blow the dust away and give it a use... Found out it won't work with Tor Browser, becasue of the CPU.

Tor Browser 3.6.5 is eating 100% CPU, after few hours of either usage either staying idle (in order to keep socksport open for other torified applications).

Can you try an experiment? Use about:config to toggle extensions.torbutton.versioncheck_enabled to false. We'd like to know if doing this eliminates the hang.

comment:18 in reply to:  17 Changed 5 years ago by douggard

Resolution: worksforme
Status: newclosed

Replying to cypherpunks:

Replying to s7r:

At the yearly cleanig of the garage found an old box which was used at the office for accounting purposes, decided to blow the dust away and give it a use... Found out it won't work with Tor Browser, becasue of the CPU.

Tor Browser 3.6.5 is eating 100% CPU, after few hours of either usage either staying idle (in order to keep socksport open for other torified applications).

Can you try an experiment? Use about:config to toggle extensions.torbutton.versioncheck_enabled to false. We'd like to know if doing this eliminates the hang.

This seems to have worked for me.

comment:19 Changed 9 months ago by adrelanos

Resolution: worksforme
Status: closedreopened

The previous poster (although 4 years ago) shouldn't have closed the ticket with new status worksforme. With all due respect, unless I missed something (search site:torproject.org "douggard"), I don't think douggard is a developer who should close tickets that way. Looks like a mistake.

toggle extensions.torbutton.versioncheck_enabled to false is a workaround but not a bugfix for this ticket.

This issue as described in the original ticket is still happening. Therefore reopening.

Could it be related to 10 years Firefox upstream unfixed bug High CPU on Linux even when in the background, possibly due to frequent polling?

comment:20 Changed 2 months ago by Anonymous75

for me in windows too like this with tor browser 8.5.5

comment:22 Changed 7 days ago by speedtester

I'm having high cpu usage with version 9.0.1 only when using a profile with torlauncher.prompt_at_startup and start_tor set to false, to access clearnet or other proxies.
Tried setting versioncheck_enabled to false, it helped once, but maybe I've changed something else too.
Since ever then, I can't figure out what setting helped, as I can't fix the other profiles.
I've figured out the below 2 threads are the hoggers:
-firefox.exe!Ordinal0+0x11x0
-ucrtbase.DLL!oClpow+0x10

Hope it helps.

comment:23 Changed 7 days ago by speedtester

Setting extensions.torlauncher.control_host to "" and extensions.torlauncher.control_port to "0" solved the problem.

comment:24 Changed 5 days ago by cypherpunks

This happens to me quiet often with a Whonix setup.

Note: See TracTickets for help on using tickets.