Opened 7 years ago

Closed 5 years ago

#8597 closed defect (duplicate)

Catch res_n* functions on systems that support them

Reported by: sysrqb Owned by: sysrqb
Priority: Medium Milestone:
Component: Core Tor/Torsocks Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We should overload the res_n* functions on systems that support them. Currently we catch res_query and it's family, but not the newer res_n* set. They've been around for a while now, there are likely programs that could be trying to perform dns resolution using udp and failing.

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by sysrqb

Owner: changed from ioerror to sysrqb
Status: newassigned

comment:2 Changed 5 years ago by dgoulet

Resolution: duplicate
Status: assignedclosed

Duplicate of #11723. Closing this one because new one asks a question about this feature. :)

Note: See TracTickets for help on using tickets.