Opened 7 years ago

Closed 6 years ago

#8612 closed defect (fixed)

When the collector is down, ooniprobe hangs

Reported by: hellais Owned by: hellais
Priority: Very High Milestone:
Component: Archived/Ooni Version:
Severity: Keywords: SponsorH201210
Cc: aagbsn Actual Points:
Parent ID: #5877 Points:
Reviewer: Sponsor:

Description

When a collector is not reachable (host resolution fails) ooniprobe will hang.

This is the backtrace:

[D] Adding report entry task <ooni.tasks.ReportEntry object at 0x104196f50>
[D] Writing report with YAML reporter
[D] Adding report entry task <ooni.tasks.ReportEntry object at 0x1038ec590>
Traceback (most recent call last):
  File "/XXXXXXXXXXX/reporter.py", line 339, in createReport
    bodyProducer=bodyProducer)
HostUnreachable
[!] Failed to open <ooni.reporter.OONIBReporter object at 0x104196f90> reporter, giving up...
[!] Reporter <ooni.reporter.OONIBReporter object at 0x104196f90> failed, removing from report...

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by hellais

Keywords: SponsorH201210 added; SponsorH201212 removed
Parent ID: #5877

comment:2 Changed 7 years ago by hellais

Status: newneeds_revision

comment:3 Changed 6 years ago by hellais

Resolution: fixed
Status: needs_revisionclosed

Since PR#64 got merged I have not been able to reproduce this bug, so I am going to consider this fixed.

Note: See TracTickets for help on using tickets.