Opened 7 years ago

Closed 7 years ago

#8627 closed defect (fixed)

[CHROME] Google Maps Review Links Creating Error 400

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone: HTTPS-E 3.2
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E chrome 2013.3.7
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When looking up a company on Google Maps and clicking on the reviews link, I'm getting Error 400 (Bad Request) in Google Chrome. If I disable HTTPS Everywhere, the problem goes away. Here's an example link that gives me the error:

http://maps.google.com/local_url?dq=prestige&q=https://plus.google.com/113467343044809428235/about%3Fgl%3DUS%26hl%3Den-US&ved=0CFMQlQU&sa=X&ei=GkFbUcyTNIeDxAGmnoDgCA&s=ANYYN7nPyMWhtdnHUf0r3OmPwNAumwvOcQ

Attached is an example of the link I'm clicking on and the resulting error.

Child Tickets

TicketStatusOwnerSummaryComponent
#8652closedpde[patch] Google Maps local_url exclusionHTTPS Everywhere/EFF-HTTPS Everywhere

Attachments (1)

error.zip (615.0 KB) - added by cypherpunks 7 years ago.
Zip file with error

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by cypherpunks

Attachment: error.zip added

Zip file with error

comment:1 Changed 7 years ago by pde

Component: HTTPS Everywhere: ChromeEFF-HTTPS Everywhere
Keywords: httpse-ruleset-bug added

comment:2 Changed 7 years ago by pde

Summary: Google Maps Review Links Creating Error 400 in Chome[CHROME] Google Maps Review Links Creating Error 400

I was unable to reproduce this bug in Chrome 27, but I was able reproduce it in Chromium 25...

comment:3 Changed 7 years ago by pde

Okay, the plot thickens. I can reproduce this in Chromium 25 and Firefox, but not Chrome 27...

comment:4 Changed 7 years ago by pde

Strangely the URL in the top bug report is (no longer?) a good example case for me, in the sense that it gives the error regardless of whether I turn off HTTPS Everywhere or not. But if I do a fresh search on maps.google.com, I get a repro case. Right now this link reproduces for me:

http://maps.google.com/local_url?dq=pickle&q=https://plus.google.com/118115007048161513463/about%3Fgl%3DUS%26hl%3Den-US&ved=0CF4QlQU&sa=X&ei=A3pbUfnKC8iQswb_yYHgAw&s=ANYYN7mEMH2UINOJcinKjSzjK5orKrKOkw

Perhaps these buggy links also have serverside expiry times?

comment:5 Changed 7 years ago by pde

Milestone: HTTPS-E 3.1.5

Looks like someone has proposed a patch at our end for this (#8652). I will apply that but also ping Google about this again.

comment:6 Changed 7 years ago by schoen

All local_url links generated with searches on Google Maps fail for me in Firefox (without the new exclusion).

comment:7 Changed 7 years ago by pde

Resolution: fixed
Status: newclosed

We should test google maps extensively before launch, but I think the hackaround for this should be in place.

Note: See TracTickets for help on using tickets.