Opened 6 years ago

Closed 4 years ago

#8633 closed defect (worksforme)

Link text overlaps with normal text making some websites unreadable

Reported by: cypherpunks Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability-website, tbb-firefox-patch
Cc: gk, michael@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Articles on http://huffingtonpost.com/ have link text that is missized and overlaps with normal text. The result is unreadable.

Zooming in and out fixes the text sizes.

Child Tickets

Change History (10)

comment:1 Changed 6 years ago by mikeperry

Keywords: tbb-usability-website added
Priority: majorcritical
Summary: Link text missized on some sites with TBB-2.3.25-5Link text overlaps with normal text making some websites unreadable

I reproduced this. Disabling our font limits allows the text to render properly.

It's interesting that zoom also fixes it. I wonder if we just need to schedule a CSS reflow after we begin limiting fonts, or if this is due to the fallback fonts that get used while web-fonts load (#8455).

I would say this is a pretty damn serious usability issue.. Certainly not something that should be ignored forever. Unfortunately, it will probably require me to understand even more deep magic about CSS rendering behaviors to fix :/.

comment:2 Changed 6 years ago by gk

Cc: g.koppen@… added

While investigating the crashes I stumbled over this as well (I guess). Just as a data point: setting "browser.display.use_document_fonts" to "0" helped in all those cases...

comment:3 Changed 6 years ago by mikeperry

Setting gfx.downloadable_fonts.fallback_delay to 300000 prevents this from happening to me. Sounds like we may have ourselves a dup of #8455 here..

comment:4 in reply to:  3 Changed 6 years ago by mikeperry

Replying to mikeperry:

Setting gfx.downloadable_fonts.fallback_delay to 300000 prevents this from happening to me. Sounds like we may have ourselves a dup of #8455 here..

Gah, strike that, I can't reproduce the textwrap problem on huffingtonpost no matter what I do now.. :/

comment:5 Changed 5 years ago by michael

Cc: michael@… added

comment:6 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:7 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser
Owner: changed from mikeperry to tbb-team

comment:8 Changed 5 years ago by gk

Cc: gk added; g.koppen@… removed

comment:9 Changed 4 years ago by Eldar

Severity: Normal

comment:10 Changed 4 years ago by gk

Resolution: worksforme
Status: newclosed
Version: Tor: 0.2.3.25

Works for me with 6.0a2.

Note: See TracTickets for help on using tickets.