Opened 6 years ago

Closed 5 years ago

#8647 closed defect (fixed)

vidalia exited abnormally. exit code 139 on tor-browser-gnu-linux-x86_64-2.3.25-6-dev-es-ES

Reported by: caralu Owned by: erinn
Priority: Medium Milestone: TorBrowserBundle 2.3.x-stable
Component: Applications/Tor bundles/installation Version: Tor: unspecified
Severity: Keywords:
Cc: killyourtv@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have tor-browser-gnu-linux-x86_64-2.3.25-6-dev-es-ES  on Ubuntu 12.04 X64 but when I try to run it I `ve: "vidalia exited abnormally. exit code 139 "  

$ ./start-tor-browser --debug

Debug enabled.



Starting Vidalia now


Launching Vidalia from: /home//TOR_Bundle/tor-browser_es-ES
Segmentation fault (core dumped)


Vidalia exited with the following return code: 139

I have downloaded the x86 version and this version run into my system fine without any trouble, so I think the problem is about X86_64 version.

What should I do for have tor-browser-gnu-linux-x86_64-2.3.25-6-dev-es-ES or any new version running on Ubuntu X64?

Child Tickets

Change History (3)

comment:1 Changed 6 years ago by kytv

Cc: killyourtv@… added

I can also reproduce this using both

  • tor-browser-gnu-linux-x86_64-2.3.25-10-dev-en-US.tar.gz
  • tor-browser-gnu-linux-x86_64-2.4.15-beta-1-dev-en-US.tar.gz

on Debian Sid, kernel 3.10-1-amd64

Running the commands manually I receive the following:

LD_LIBRARY_PATH=/home/user/tbb/tor-browser_en-US/Lib LDPATH=/home/user/tbb/tor-browser_en-US/Lib/ ./App/vidalia --datadir ./Data/Vidalia/ --style Cleanlooks

Cannot mix incompatible Qt library (version 0x40805) with this library (version 0x40801)
Aborted

If I don't set the LD_LIBRARY_PATH and LDPATH variables it'll run successfully.

(maybe this will be of use):

$ ldd App/vidalia
        linux-vdso.so.1 (0x00007fff17a00000)
        libQtGui.so.4 => /home/user/tbb/tor-browser_en-US/Lib/libQtGui.so.4 (0x00007f4a57738000)
        libQtXml.so.4 => /home/user/tbb/tor-browser_en-US/Lib/libQtXml.so.4 (0x00007f4a574f0000)
        libQtNetwork.so.4 => /home/user/tbb/tor-browser_en-US/Lib/libQtNetwork.so.4 (0x00007f4a57198000)
        libQtCore.so.4 => /home/user/tbb/tor-browser_en-US/Lib/libQtCore.so.4 (0x00007f4a56ca8000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4a56960000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4a56660000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f4a56448000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f4a56098000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4a55e78000)
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f4a55c70000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f4a55a68000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f4a55768000)
        libpng15.so.15 => /home/user/tbb/tor-browser_en-US/Lib/libpng15.so.15 (0x00007f4a55538000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f4a55320000)
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f4a55080000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f4a54e30000)
        libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007f4a54c28000)
        libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007f4a54a08000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f4a547f8000)
        libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f4a545b8000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f4a543a0000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f4a54060000)
        libssl.so.1.0.0 => /home/user/tbb/tor-browser_en-US/Lib/libssl.so.1.0.0 (0x00007f4a53e00000)
        libcrypto.so.1.0.0 => /home/user/tbb/tor-browser_en-US/Lib/libcrypto.so.1.0.0 (0x00007f4a53a48000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f4a53840000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f4a58470000)
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f4a53600000)
        libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f4a533f8000)
        libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f4a533f0000)
        libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f4a531c0000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f4a52fa0000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f4a52d98000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f4a52b90000)

comment:2 Changed 5 years ago by caralu

With the last release 3.5 I can run X64 normally. Thank you so much!

comment:3 Changed 5 years ago by arma

Resolution: fixed
Status: newclosed

Great. Closing this one then. All hail the new Tor launcher.

Note: See TracTickets for help on using tickets.