Opened 7 years ago

Closed 7 years ago

#8675 closed defect (duplicate)

Unnecessary connection to check.torproject.org

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.1.4
Severity: Keywords:
Cc: intrigeri@… Actual Points:
Parent ID: #7179 Points:
Reviewer: Sponsor:

Description

On every startup, HTTPS-Everywhere version 3.1.4 (Firefox 20.0) connects to check.torproject.org (HTTPS). This automatic connection doesn't happen when HTTPS-Everywhere is disabled. By looking at the source code of HTTPS-Everywhere, it seems to me that the purpose of this connection is to check whether Firefox is connected through a TOR proxy.

This TOR check is not needed when SSL-Observatory is disabled, which is the case here.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by intrigeri

Cc: intrigeri@… added

comment:2 Changed 7 years ago by pde

Parent ID: #7179

This is not really a bug. HTTPS Everywhere checks to see if Tor is present so that it knows how to render the Observatory preferences window, if the user chooses to open it. That window needs to have all the tor options greyed out if tor is not available, and checking requires a connection to check.torproject.org which takes a long time to perform if it only begins after the user has asked for that window to open.

Having said that, there is a real bug here, which is #7179. The DNS query for check.torproject.org is going out over the regular network, when in fact it should be using Tor.

comment:3 Changed 7 years ago by pde

Resolution: duplicate
Status: newclosed

In fact I'm just going to close this as a dupe of #7179.

Note: See TracTickets for help on using tickets.