Opened 6 years ago

Closed 6 years ago

#8681 closed defect (worksforme)

Stem Integ Tests fail on Windows

Reported by: ashishnitinpatil Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Stem Version:
Severity: Keywords: testing easy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Stem Integ tests use "resource" library which is not available under Windows operating system. Thus, when the tests are run under Windows, python gives "Import Error" for "resource".

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by atagar

Keywords: testing added

comment:2 Changed 6 years ago by atagar

Keywords: easy added

comment:3 Changed 6 years ago by ashishnitinpatil

Seems like the issue is resolved. The test was modified/removed.

comment:4 Changed 6 years ago by atagar

Resolution: worksforme
Status: newclosed

Looks like the resource module was used in the descriptor tests to check if we were gobbling too much memory. It was removed in commit bc155d6...

https://gitweb.torproject.org/stem.git/commitdiff/bc155d6

I didn't realize it was platform dependent. Thanks for the catch! I'll keep it in mind for the future.

Note: See TracTickets for help on using tickets.