Opened 6 years ago

Closed 6 years ago

#8726 closed defect (duplicate)

Windows TBB crashes on any Amazon.com product page

Reported by: matt Owned by: mikeperry
Priority: Medium Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords: tbb-crash, MikePerry201304
Cc: mikeperry, g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by Sherief)

You can reproduce this crash by doing the following:

Using TBB 2.3.25-6 in the standard configuration, go to amazon.com and search for any product. Click on the link to one of the product results and wait for the page to fully load. If you do not get a crash, keep scrolling to the bottom of the page and wait for the rest of the page to load. If you still have not got a crash at this point, close the tab.

Child Tickets

Change History (15)

comment:1 Changed 6 years ago by matt

I was not able to reproduce this issue on Debian--only Windows.

comment:2 Changed 6 years ago by runa

I am able to reproduce this on Windows 7 64-bit. I search for an item, click on the first result, wait for the pager to load, and see a message telling me the TorBrowser has stopped working.

comment:3 Changed 6 years ago by gk

Cc: g.koppen@… added

comment:4 Changed 6 years ago by runa

Summary: TBB crashes on any Amazon.com product pageWindows TBB crashes on any Amazon.com product page

comment:5 in reply to:  2 ; Changed 6 years ago by Sherief

Description: modified (diff)

Replying to runa:

I am able to reproduce this on Windows 7 64-bit. I search for an item, click on the first result, wait for the pager to load, and see a message telling me the TorBrowser has stopped working.

According to RT ticket #9240 It should be also reproducible on OS X 10.6.8, Awaiting user feedback on which version (32/64bit)

comment:6 Changed 6 years ago by arma

Confirmed on Linux 64-bit TBB.

comment:7 Changed 6 years ago by gk

While I can reproduce the problem easily on Windows I am not able to do so on Linux 64-bit. But the interesting thing is I am currently not able to reproduce it either if I build a Tor Browser on Windows myself...

comment:8 in reply to:  5 Changed 6 years ago by Sherief

Replying to Sherief:

Replying to runa:

I am able to reproduce this on Windows 7 64-bit. I search for an item, click on the first result, wait for the pager to load, and see a message telling me the TorBrowser has stopped working.

According to RT ticket #9240 It should be also reproducible on OS X 10.6.8, Awaiting user feedback on which version (32/64bit)

User reported back he's using OS X 10.6.8  TBB 2.3.25-6 64-bit.

comment:9 Changed 6 years ago by mikeperry

Component: Tor bundles/installationFirefox Patch Issues
Keywords: tbb-crash MikePerry201304 added; browser removed
Owner: changed from erinn to mikeperry

gk: I am also unable to reproduce this on a custom build that contains my fix for #8628 (which has been in origin/maint-2.4 for the past week or so). I suspect this might mean this is a dup of that bug, but it could also be due to build differences :/.

We're going to release a TBB-alpha soon with that fix, so someone can compare two official builds before and after that patch and verify the crash happens prior to #8628 patch but is fixed afterwords.

comment:10 Changed 6 years ago by mikeperry

Katya on tor-qa is reporting that the alpha has fixed the crashing. Can someone on Windows confirm:
https://people.torproject.org/~erinn/qa/alpha/0.2.4.12-alpha/

Absent input, at the end of the month I'm calling this a dup of #8628.

comment:11 Changed 6 years ago by arma

I just tried the old 2.3.25-6-dev again on my 64-bit Linux. It took quite a few page loads and scrolling around and stuff, but the browser eventually disappeared.

I then tried the 2.4.12-alpha-1-dev and spent a while trying to crash it. So far so good.

comment:12 in reply to:  10 Changed 6 years ago by matt

Replying to mikeperry:

Katya on tor-qa is reporting that the alpha has fixed the crashing. Can someone on Windows confirm:

I just tested this on tor-browser-2.4.12-alpha-1_en-US.exe on Windows 7 and I did not experience any crash. I say great job.

comment:13 in reply to:  10 Changed 6 years ago by Sherief

Replying to mikeperry:

Katya on tor-qa is reporting that the alpha has fixed the crashing. Can someone on Windows confirm:
https://people.torproject.org/~erinn/qa/alpha/0.2.4.12-alpha/

Absent input, at the end of the month I'm calling this a dup of #8628.

I just test both packages on Windows 7 64-bit, I was able to crash 2.3.25-6 using 6 tabs of amazon. However, 2.4.12-alpha-1 worked perfectly.

Side note:
I am not sure if this is related to FF 17 or TBB it self but Both Browsers (2.3.25-6, 2.4.12-alpha-1) were a bit sluggish while scrolling than a normal FF (version 20.0.1 was smoother).

comment:14 Changed 6 years ago by mikeperry

See #8352. We disabled optimization in both the Windows and Linux builds due to a crash bug in the build process on Debian that appeared in FF17-ESR

When Wheezy releases next week, we may be able to turn the optimization flag back on.

comment:15 Changed 6 years ago by mikeperry

Resolution: duplicate
Status: newclosed

Calling this a dup of #8628. The next TBB-stable should have the fix from TBB-alpha.

Note: See TracTickets for help on using tickets.