Opened 11 years ago

Last modified 11 years ago

#875 closed defect (User disappeared)

b.docShell is Null during toggle or new window

Reported by: mave Owned by:
Priority: Low Milestone:
Component: Applications/Torbutton Version: 1.2.0rc5
Severity: Keywords:
Cc: mave, arma, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,
so it seems nobody is interested in my last task (ID 865)(I suppose because of Severity) I produce a new one. because
it is bothersome meanwhile that the browser has to start twice due to the reported bug (see below). Additional
the Firefox is always starting with 'Tor aktiviert' although I left it last with 'Tor deaktiviert'. Please, help.

Best regards
Jens

Hello,

I have a problem and I did not find an answer.
The problem is:
When I disable torbutton and no services (in connect with tor) is running (I disabled them) I have some trouble with
Firefox (Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3).
When I start the browser the browser window is empty. It seems it stops. Then I additionally have to click home
button or to use another URL that the browser normally runs. During work often appears following message (I suppose
when Java Environment is running)
'Torbutton: Please file bug report! Error applying Tor settings: TypeErrpor:b.docShell is Null.'

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (9)

comment:1 Changed 11 years ago by mikeperry

Let me see if I understand the report (please clarify where I have questions)

  1. Your tor service is not running.
  2. You start firefox (You set it to start in Tor mode?)
  3. Your firefox homepage fails to load (is this with any homepage?)
  4. Sometime later (randomly, or during toggle?) the error message about b.docShell appears. (Is tor running yet at this point?)

What other extensions do you have installed?

You also mentioned Java. Does #3 ever happen if you disable java entirely?

Does it always happen after visiting a java website and toggling Tor?

comment:2 Changed 11 years ago by mikeperry

I tried to reproduce this. I can't seem to do it.

Are you using the default proxy settings, or SOCKS?

comment:3 Changed 11 years ago by mave

  1. Tor is not running
  2. I did not set it in Tor mode
  3. All of browsers are closed
  4. I start firefox via icon or it automaticcally start by clicking an URL in another application then
  5. Your #2: Yes, with any
  6. Forget java, it only was a suspicion. It happens always !

Perhaps, I could send you some logs?! If so, please, say which logs and where I can find them, because I do not know which one you need.
Perhaps, we can find the problem next days. If not, I install all apps again, firefox, Tor etc., because the problem is irritating.

comment:4 Changed 11 years ago by mikeperry

Ok, let me give you an example of the type of report I need. I just tried to reproduce your issue and did the following:

I use Tor and Privoxy.

  1. Killed both Tor and Privoxy processes
  2. Started up Firefox. It started with "Tor Disabled"
  3. Clicked the Torbutton to change it to "Tor Enabled"
  4. Typed http://www.google.com in the URL bar, causing firefox to display "Proxy Server Refused Connection"
  5. Opened a new window for a new URL, got the same message.
  6. Clicked the torbutton to change it to "Tor Disabled"
  7. Hit enter in the URL of one of the "Refused connection" windows
  8. Opened a new window. Visited http://www.google.com

At no point in any of this did I ever get a docShell is null popup. Can you please try again to describe exactly
what you did to get the popup message, in detail, and also specify if you use privoxy and Tor, or just Tor?

comment:5 Changed 11 years ago by mikeperry

Ok, well absent any more information, I added a check to prevent the null b.docShell from aborting the Tor toggle in
r18969. I'd still like to know why its caused, but this is no longer critical/high priority now that toggle should
succeed.

Please do update the bug with more info if you are still around, though.

comment:6 Changed 11 years ago by mave

Many thanks for your efforts. I'm going to sweep firefox and instal new. Perhaps, I did something wrong during Installation of Tor.
The failure in its appearance is easy.

  1. When I click the firefox-Icon, a sreen-window appears

'Die Suchmaschine konnte nicht heruntergeladen werden von:
Firefox'

  1. then I click ok
  2. then I have to click the home-button again
  3. then it normally starts and I can work with firefox
  4. It is allways the same way, except for firefox is started by another app

However, I do this way written above.
Many thanks,
good luck
Jens

comment:7 Changed 10 years ago by mikeperry

Did your reinstall fix this? Any ideas if there was another addon that caused the problem?

comment:8 Changed 10 years ago by mave

Yes. It works perfect.
However, I did not search the reason of the failure we speak about. Sorry, I am bit busy at the moment. So I did not install Tor and Privoxy again. I missed to install some adds as well. To reconstruct the failure I have a lack of time at present. Sorry for this. Many thanks for your help and efforts.
Best greetings
Jens

comment:9 Changed 10 years ago by mikeperry

flyspray2trac: bug closed.
Hopefully someone will report the warn if it shows up.

Note: See TracTickets for help on using tickets.