Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#8807 closed defect (fixed)

Installing obfsproxy

Reported by: torland Owned by: asn
Priority: Medium Milestone:
Component: Archived/Obfsproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Today I tried to install obfsproxy according to https://www.torproject.org/projects/obfsproxy-instructions.html.en
on an ubuntu server.

The page suggest that installing via "pip install obfsproxy" is a no-brainer. But the first install failed because of of missing gcc, what I resolved with apt-get install build-essentials. The second install because of missing phython-dev package. I suggest to update obfsproxy-instructions.html.en that having build-essentials and python-dev is a requirement.

regards torland

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by asn

Hi,

we added python-dev to the apt-get install package list. Should we also add build-essentials? I'm asking because I've never heard anyone else complaining.

comment:2 Changed 7 years ago by torland

Thanks. If it is required to have build-essentials to install obfsproxy I would add it. I don't think that we can expect that it is available on any server.

comment:3 Changed 7 years ago by asn

OK. Pushed changes to website that add the build-essential package to the installation list.

comment:4 Changed 7 years ago by asn

Resolution: fixed
Status: newclosed

comment:5 Changed 7 years ago by torland

Great, thanks for taking care.

Note: See TracTickets for help on using tickets.