Opened 6 years ago

Closed 4 years ago

#8838 closed defect (worksforme)

AttributeError: 'Version' object has no attribute 'meets_requirements'

Reported by: gsathya Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

arm :: (master) » ./arm                                                                                                                                                                            ~/arm  
Traceback (most recent call last):  File "./src/starter.py", line 478, in <module>
    cli.controller.startTorMonitor(time.time() - initTime)
  File "/home/gsathya/arm/src/cli/controller.py", line 564, in startTorMonitor
    curses.wrapper(drawTorMonitor, startTime)  File "/usr/lib/python2.6/curses/wrapper.py", line 43, in wrapper
    return func(stdscr, *args, **kwds)  File "/home/gsathya/arm/src/cli/controller.py", line 618, in drawTorMonitor
    control.redraw(False)  File "/home/gsathya/arm/src/cli/controller.py", line 346, in redraw
    panelImpl.redraw(force)  File "/home/gsathya/arm/src/util/panel.py", line 405, in redraw
    self.draw(self.maxX, self.maxY)  File "/home/gsathya/arm/src/cli/torrcPanel.py", line 178, in draw
    corrections = dict((lineNum, (issue, msg)) for lineNum, issue, msg in loadedTorrc.getCorrections())
  File "/home/gsathya/arm/src/util/torConfig.py", line 797, in getCorrections
    skipValidation |= (torVersion is None or not torVersion.meets_requirements(stem.version.Requirement.GETINFO_CONFIG_TEXT))
AttributeError: 'Version' object has no attribute 'meets_requirements'

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by atagar

Resolution: worksforme
Severity: Normal
Status: newclosed

Cleaning up old tickets. Nyx is undergoing a rewrite, if this is still relevant then feel free to reopen.

Note: See TracTickets for help on using tickets.