Opened 7 years ago

Closed 7 years ago

#8854 closed defect (not a bug)

64 bit mac build does not appear as 64 bit in Mac OS X

Reported by: ev11xjk5t Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.4.12-alpha
Severity: Keywords: osx
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Mac OS X 10.8.3 (also tested on 10.7.5) does not recognize the TorBrowser-en-US app as a 64-bit app.

--- Steps to reproduce the problem :

Download the latest 64-bit stable or alpha build of Tor for Mac OS X.
Move the file "TorBrowser-en-US" in the Applications folder
Launch "System Information"
Go to "Software", then "Applications"
Check "TorBrowser-en-US". In the column "64-bit (intel)", it says "No".

When launched, Vidalia and Tor Browser appear as 64 bit in system monitor, so I guess this is just some kind of missing declaration in an info.plist file...

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by ev11xjk5t

Component: - Select a componentTor

comment:2 Changed 7 years ago by nickm

Component: TorTor bundles/installation
Keywords: osx added
Milestone: Tor: 0.2.4.x-final
Owner: set to erinn
Priority: majornormal

comment:3 Changed 7 years ago by erinn

I think this is probably because the launch script is just a shell script and architecture-independent and is unrelated to the .plist files. Vidalia doesn't declare any architecture in its .plist file, and TorBrowser has some information but it lists both i386 and x86_64 under the LSMinimumSystemVersionByArchitecture key...

comment:4 Changed 7 years ago by nickm

okay. Shall we close as not-a-bug then?

comment:5 Changed 7 years ago by erinn

Resolution: not a bug
Status: newclosed

Yeah. After looking around a bit I don't see that there is a way to do this and I'm not sure it's desired behavior anyway. ev11xjk5t, if you feel differently or can find me some more relevant documentation about this, feel free to re-open (as a task or enhancement though, not a defect). Thanks.

Note: See TracTickets for help on using tickets.