Opened 11 years ago

Last modified 7 years ago

#887 closed defect (Fixed)

relay starting with old consensus doesn't bootstrap for a long time

Reported by: arma Owned by:
Priority: Low Milestone: 0.2.1.x-final
Component: Core Tor/Tor Version: 0.2.1.8-alpha
Severity: Keywords:
Cc: arma, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I ran moria5 for a while in October. It worked fine then as a fast relay.

Now I start it up in December, and it can't bootstrap. It looks like it's
believing the IP addresses it found in the consensus.

It was missing ides's cert, so it kept trying to fetch that, from random
relays listed in the consensus that were pretty much long dead.

Eventually it did bootstrap. It took 20 minutes or so. I'm not sure why;
I speculate it's because it found a working mirror.

I put the offending datadir in http://freehaven.net/~arma/moria5-broken-datadir.tar.gz

It would be good if somebody could pull that down and see if their svn trunk
also gets stuck at
Dec 16 19:50:06.089 [notice] Bootstrapped 10%: Finishing handshake with directory server.
Dec 16 19:50:06.732 [notice] Bootstrapped 15%: Establishing an encrypted directory connection.
Dec 16 19:52:07.098 [notice] No current certificate known for authority ides; launching request.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (4)

comment:1 Changed 11 years ago by arma

See also r17917

comment:2 Changed 11 years ago by arma

And also r17993

I'm going to call this fixed.

comment:3 Changed 11 years ago by arma

flyspray2trac: bug closed.

comment:4 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.