Opened 7 years ago

Closed 7 years ago

#8883 closed defect (duplicate)

Internal error in Tor 2.4.12-Alpha (a different one)

Reported by: LoneRanger1012 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.12-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

[Thu May 16 08:17:51 2013] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1952491, but I should be at 1952656
"

This is the 50th (or more) error in rapid succession. The beginning of the log file has disappeared.

Child Tickets

Change History (4)

comment:1 in reply to:  description Changed 7 years ago by LoneRanger1012

Replying to LoneRanger1012:

[Thu May 16 08:17:51 2013] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1952491, but I should be at 1952656
"

This is the 50th (or more) error in rapid succession. The beginning of the log file has disappeared.

The following are the last several in the advanced list:

May 16 08:17:51.062 [Warning] Couldn't dump microdescriptor (wrote 4294967295 out of 321): Invalid argument
May 16 08:17:51.072 [Warning] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1952491, but I should be at 1952656
May 16 08:17:51.072 [Warning] Error replacing "C:/Users/David L Carlson/AppData/Roaming/tor\cached-microdescs": Permission denied
May 16 08:17:51.072 [Warning] Error rebuilding microdescriptor cache: Permission denied
May 16 08:29:49.735 [Warning] Gzip returned an error: stream error
May 16 08:29:49.735 [Warning] write_to_buf failed. Closing connection (fd -1).
May 16 08:30:33.155 [Warning] Gzip returned an error: stream error
May 16 08:30:33.155 [Warning] write_to_buf failed. Closing connection (fd -1).
May 16 08:32:47.943 [Warning] Gzip returned an error: stream error
May 16 08:32:47.943 [Warning] write_to_buf failed. Closing connection (fd -1).

comment:2 Changed 7 years ago by LoneRanger1012

This is running in Windows 7 Pro 64 bit.

comment:3 Changed 7 years ago by LoneRanger1012

Component: - Select a componentTor

comment:4 Changed 7 years ago by nickm

Resolution: duplicate
Status: newclosed

Looks like a duplicate of #8822.

Note: See TracTickets for help on using tickets.