Opened 7 years ago

Closed 7 years ago

#8888 closed defect (fixed)

gettor@gettor.torproject.org alias not working

Reported by: peter Owned by:
Priority: Medium Milestone:
Component: Applications/GetTor Version:
Severity: Keywords:
Cc: sukhbir.in@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In the past week, I've attempted to send mail to the GetTor mail robot addresses

gettor@…
gettor@…

no subject, message body = 'help', and have not received any replies.

Am I doing it wrong, or is the alias down? Something else?

Child Tickets

Change History (13)

comment:1 Changed 7 years ago by phobos

Resolution: not a bug
Status: newclosed

It doesn't work because that alias doesn't exist. gettor@… is the correct alias, as the documentation shows.

comment:2 in reply to:  1 Changed 7 years ago by peter

Replying to phobos:

It doesn't work because that alias doesn't exist. gettor@… is the correct alias, as the documentation shows.

I've sent mail to both addresses several times since 5/10/2013 with no response from either. Tried again this morning, so far no response.

Both addresses were listed in different places on torproject.org:

gettor @ torproject.org
GetTor page
(https://www.torproject.org/projects/gettor.html.en)

gettor @ torproject.org
Short user manual
(https://www.torproject.org/dist/manual/short-user-manual_en.xhtml)

gettor @ gettor.torproject.org
Tor FAQ
(https://www.torproject.org/docs/faq.html.en#GetTor).

comment:3 Changed 7 years ago by peter

Resolution: not a bug
Status: closedreopened

comment:4 Changed 7 years ago by weasel

Resolution: not a bug
Status: reopenedclosed

That's a different bug then. This one was about 'gettor@…' not working.

Please don't recycle tickets. If you think there's an issue with @gettor.torproject.org please file a new bug, or contact the support team.

comment:5 in reply to:  4 Changed 7 years ago by karsten

Resolution: not a bug
Status: closedreopened
Summary: GetTor@torproject.org alias not workinggettor@gettor.torproject.org alias not working

Replying to weasel:

That's a different bug then. This one was about 'gettor@…' not working.

Well, that's what the subject says, but the description also mentions gettor@… not working.

Please don't recycle tickets. If you think there's an issue with @gettor.torproject.org please file a new bug, or contact the support team.

To be fair, I encouraged peter to reopen the ticket. And I think that was the right thing to do. It shouldn't have been closed in the first place, because peter mentioned that he did try gettor@…, and it didn't work. It's just that the subject was slightly misleading. Re-opening and changing the subject. It's still the same issue.

The fact that gettor@… is mentioned in two places in the documentation is another bug, or maybe two. Opening a new ticket for that.

peter, thanks for reporting these issues!

comment:6 Changed 7 years ago by kaner

Seems like something happened to dkimverify?

procmail: [29855] Sun May 26 20:34:14 2013
procmail: Score:       1       1 "From .*@gmail.com"
procmail: Score:       0       1 "From .*@yahoo.com"
procmail: Score:       0       1 "From .*@yahoo.cn"
procmail: Executing "dkimverify"
procmail: Non-zero exitcode (1) from "dkimverify"
procmail: Match on ! "dkimverify"
procmail: Assigning "LASTFOLDER=/srv/gettor.torproject.org/mail-failed/new/1369600454.29855_0.getulum"
procmail: Notified comsat: "gettor@0:/srv/gettor.torproject.org/mail-failed/new/1369600454.29855_0.getulum"

When I try the same mail on the command line:

$ cat /srv/gettor.torproject.org/mail-failed/new/1369600454.29855_0.getulum  | dkimverify 
signature ok
gettor@getulum:~$ echo $?
0

comment:7 Changed 7 years ago by kaner

Testing it more, it seems only mails from GMail get rejected by dkimverify, Yahoo seems to work. I have no idea why.

comment:8 Changed 7 years ago by sukhbir

Cc: sukhbir.in@… added

comment:9 Changed 7 years ago by arma

I vaguely recall that sukhbir and kaner were talking to the dkimverify developer about this issue? Did that get dropped on the floor?

comment:10 Changed 7 years ago by arma

(It sounds like a bug in dkimverify.)

comment:11 Changed 7 years ago by arma

weasel points us to http://bugs.debian.org/711817

comment:13 Changed 7 years ago by lunar

Resolution: fixed
Status: reopenedclosed
<weasel> weasel@valiant:~$ ssh getulum.torproject.org dpkg -l python-dkim | tail -n1
<weasel> ii  python-dkim                        0.5.3-1+deb7u1                all          Python module for DKIM signing and verification

The fixed version has been deployed.

Note: See TracTickets for help on using tickets.