Opened 6 years ago

Closed 6 years ago

#8939 closed defect (duplicate)

Tor browser crashes when logging in to file hoster cloudzer.net

Reported by: tiger Owned by: mikeperry
Priority: High Milestone: TorBrowserBundle 2.3.x-stable
Component: Firefox Patch Issues Version: Tor: 0.2.3.25
Severity: Keywords: tbb-crash
Cc: g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor browser crashes when logging in to files hoster cloudzer.net

I use the latest Tor Browser Bundle (Version 2.3.25-8 - Linux, Unix, BSD (64-Bit))

This issue didn't happen in earlier versions of the bundle.

Anything else you need to know?

Child Tickets

Change History (7)

comment:1 in reply to:  description Changed 6 years ago by gk

Cc: g.koppen@… added
Component: TorFirefox Patch Issues
Keywords: tbb-crash added
Milestone: TorBrowserBundle 2.3.x-stable
Owner: set to mikeperry
Priority: normalmajor

Replying to tiger:

Anything else you need to know?

No, thanks. With a debug build I get the following assertions:

###!!! ASSERTION: bad font face url passed to fontloader: 'aFontFaceSrc && !aFontFaceSrc->mIsLocal', file /home/firefox64/TBB/CrashFontDebug/mozilla-esr17/layout/style/nsFontFaceLoader.cpp, line 809
###!!! ASSERTION: null font uri: 'aFontFaceSrc->mURI', file /home/firefox64/TBB/CrashFontDebug/mozilla-esr17/layout/style/nsFontFaceLoader.cpp, line 810

This does neither happen with a vanilla Firefox (+ the Tor Browser .mozconfig) nor a patched Firefox without the patch 0011. Looking a bit deeper then 2a543b9359029938dfa98f8e285fb5528104d527 is still okay but b0e19e9a7e94dcbd6e50ea3739c5b3ce218fe57c is not anymore. Thus, this seems to be a bug in the fix for #8455 and probably responsible for all the crash bugs that showed up recently...

comment:2 Changed 6 years ago by arma

I've been experiencing not infrequent Tor Browser crashes too -- Mike, let us know if we can do anything to help test a fix!

comment:3 Changed 6 years ago by mikeperry

A simple reproduction case would be useful. I've been running my own builds with that patch for over two months now and have not had any crashes. I've tried visiting a few of these random sites people are reporting (including this one and living social), but they don't crash upon non-login usage, and account creation requires making an email, twitter account, etc.

None of the news sites I visit crash either.

comment:4 Changed 6 years ago by tiger

@mikeperry: You don't even have to log in on cloudzer.net: To reproduce this bug just click on "upload" and Tor Browser crashes immediately.

comment:5 Changed 6 years ago by mikeperry

FWIW: clicking on that upload button (without an account) in my gitian-based TBB does not cause a crash.

I get a prompt asking me to enter an email address.

comment:6 Changed 6 years ago by gk

Ha! It seems I was wrong with the supposed reason for the crash: I don't get local builds to crash at all (in comment 1 I only tried debug builds but the same holds for optimized builds). Thus, a better theory is probably an issue with the TBB build process for (64bit) Linux builds. Fun.

comment:7 Changed 6 years ago by mikeperry

Resolution: duplicate
Status: newclosed

We've traced this to build issues. See #8970.

Note: See TracTickets for help on using tickets.