Opened 11 years ago

Last modified 11 years ago

#896 closed defect (Duplicate)

Torbutton overrides Toolbar customizes in iceweasel (debian)

Reported by: magic_doc Owned by:
Priority: Low Milestone:
Component: Applications/Torbutton Version: 1.2.0rc5
Severity: Keywords:
Cc: arma, mikeperry, roland Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When Torbutton Addon is enabled, customizing the Toolbar is not remembered in a new session of iceweasel:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008112309 Iceweasel/3.0.4 (Debian-3.0.4-1)

Only disabling the Addon makes the old settings effective immediately.
Espaccially the google-searchbar is most annoying on a small notebook display.

This is no interference with a different addon since the behavior is the same with a new profile an Torbutton as the
only addon installed.

Only way to get rid off is to disable the addon in the manager which is of cause no solution forever.
Can anyone reproduce the bug on his system?

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (12)

comment:1 Changed 11 years ago by mikeperry

Hrmm, I customize my toolbar regularly with the official firefox. Can you let me know exactly which toolbar
customizations aren't sticking?

comment:2 Changed 11 years ago by wwp

I face the problem too with Firefox 3.0.x in Fedora 8 and Fedora 10. Any customization the navigation toolbar will be forgotten at next restart or even when opening a new window. I'm adding NewTab button, removing search field and home button - the toolbar gets reset to defaults when I restart Firefox or when I open a new window. Workaround is to disable or uninstall the Tor Button add-on.

comment:3 Changed 11 years ago by mikeperry

I've used both Fedora 8 and Fedora 10 at various points in torbutton development and have customized my toolbars
with them. Just tried removing the search box and it stayed gone. Are you sure just opening a new window resets
the toolbars?

Can you describe a step by step process to cause the toolbars to get reset starting from a fresh Firefox start
with Torbutton disabled? Ideally if you started from a fresh firefox profile by running firefox as:

# firefox -no-remote -P

and then creating a new profile and installing only Torbutton to it.

comment:4 Changed 11 years ago by roland

I have the same problem. All the customisations in toolbar disapears when Torbutton is installed. The google bar disapears too.
I have Firefox 3.0.8, on Linux mandriva system.

comment:5 Changed 11 years ago by griffin

I had the same problem (Debian Lenny/Squeeze).
But I saw on the main page of torbutton that NoScript isn't recommended with TorButton
I tried to desactivated NoScript and now, it works, I don't know why. :D

comment:6 Changed 11 years ago by godefroy

I have the same problem here, with Firefox v3.0.x (currently 3.0.8) and Tor Button v1.2.1 under Mandriva 2009.0.

The tor button icon does not appear in the customization menu of the toolbar, and any change to the toolbar is forgotten at the next Firefox session. Disabling or uninstalling Tor Button solves the problem.
I also am using NoScripts (a must have, and I'm not going to uninstall it ever !).
The solution to my problem was to patch Tor Button v1.0.4 so that Firefox v3 accepts to install it, and to use it instead of v1.2.1: 1.0.4 got much less features, but at least it works properly...

comment:7 Changed 11 years ago by mikeperry

Hrmm.. I can't reproduce this locally on my Linux systems..

Can one of you please try to start up a fresh firefox from the command line like so:

firefox -no-remote -P

This will give you a new firefox process with the firefox profile creation/selection window open. Can you then
create a fresh profile, install torbutton and noscript to it, and see if the issue still persists? If not, can
you try either adding additional addons you have, or changing noscript settings from the default until it does
happen?

I'm wondering if it is some special noscript option you have set that is causing the problem, because the
default one allows me to do anything I want to the toolbars, and the changes are saved.

comment:8 Changed 11 years ago by mikeperry

FYI, Torbutton 1.0.4 is not a very wise recommendation. I suggest people not follow it. See:

https://www.torproject.org/torbutton/design/#attacks

I'd much rather people spend their time helping me debug this issue rather than hacking insecure and obsolete
software so that it will run and allow them to get exploited. I've provided instructions on how to help twice
now. If they are unclear, please ask for clarification.

comment:9 Changed 11 years ago by godefroy

I simply renamed my .mozilla folder, the time to do the testing (which I'm afraid can't last longer).

Here is what I noticed: after installing Tor Button v1.2.1 and when launching Firefox
from the command line, I get the following error messages from Tor Button:

Torbutton logger online
[04-10 09:12:09] Torbutton NOTE: Skipping no location: chrome://browser/content/browser.xul
[04-10 09:12:09] Torbutton NOTE: Conflict between noncrashed and normal_exit states.. Assuming crash but no session restore..
[04-10 09:12:09] Torbutton NOTE: Crash detected, attempting recovery
[04-10 09:12:09] Torbutton NOTE: Restoring cookie status
[04-10 09:12:09] Torbutton NOTE: Loading non-tor jar after crash
[04-10 09:12:09] Torbutton NOTE: Restoring tor state

Which is not coherent at all, since there has been no crash...
These messages show up every time I launch firefox (and every time after I
installed other addons).

I then Installed NoScript, and it seems to run fine with Tor Button in its default
configuration (I have no time to test every possible setting combination to try and
reproduce the bug, I afraid).

I also tried to install Ad Block, Linky, and Tab Mix Plus. Everything worked fine,
but I noticed that the toolbar was reset to its default status after Tab Mix Plus
was installed (it however kept its configuration in next sessions).

As far as I can tell, there is at least something wrong with Tor Button and its
very wrong crash detection. The bug with the toolbar might however be shared with
another extension.

As for using v1.0.4, I perfectly know what are its limitations, thank you. I am
also using Ad Block, NoScript, User Agent Switcher and Cookie Monster together
with it so to prevent leaking information too much. Note also that should I leak
some, it's not a big deal for me as I use Tor mainly to bypass country detection
schemes of some web site (the last use I made of it was to view a trailer for
a TV series, which trailer was reserved to UK users: selecting an UK TOR exit
node allowed me to bypass this stupid limitation).
I'll therefore keep using v1.0.4 till this nasty bug gets fixed. :-P

comment:10 Changed 11 years ago by mikeperry

I wasn't suggesting anything about what you should do. I was merely suggesting that other people not take
your recommendation on face without explanation and qualification. It is not a good one for all users who
have this issue.

I'm also not doubting that there is a bug or even two here, I'm merely requesting help diagnosing it, as it
does not happen for me or any other Debian and Fedora NoScript users who I've asked about it (and who have
responded to my requests).

In your original setup, was it the case that your toolbars were reset after *every* restart, or just some?

Did it happen every restart after your install of Tab Mix Plus? Or maybe every time you installed/upgraded new
extensions?

comment:11 Changed 11 years ago by godefroy

Like I explained, there is one bug that would be easily reproducible:

  • Install Firefox (or rename the ~/.mozilla folder to start afresh with a new profile)
  • Install Tor Button v1.2
  • Launch Firefox from the command line.
  • Restart Firefox.
  • Admire the "nice" log from Tor button, pretending there was a crash while there was none.

I did not pretend either the toolbar issue was an interaction between Tor Button and NoScript, but since Griffin said he was using both and had the issue only when both are enabled together, I simply confirmed in my first post that I did have the same issue (toolbar layout not remembered over sessions) and was using NoScript as well.

And yes, the toolbar is reset after *every* restart, plus the tor button icon does not appear in the customization window (from which you can normally drag buttons to drop them on the toolbar).

For me, the issue appeared after I installed Firefox v3.0 with a clean profile (no extension), then added all my favorite extensions (I don't remember in which order, sorry): I then noticed how Tor Button v1.2 was breaking the toolbar. Since then, I simply patched Tor Button v1.0.4 and installed it in place of v1.2, and I have no problem at all with it.

comment:12 Changed 10 years ago by mikeperry

flyspray2trac: bug closed.
Dup of 992.

Note: See TracTickets for help on using tickets.