Opened 6 years ago

Closed 6 years ago

#8970 closed defect (fixed)

tbb 2.3.25-8 - Linux 64bit crashes all the time

Reported by: cypherpunks Owned by: erinn
Priority: Very High Milestone: TorBrowserBundle 2.3.x-stable
Component: TorBrowserButton Version:
Severity: Keywords: tbb-crash
Cc: mikeperry, gk, erinn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It crashes occasionally while browsing random sites, no matter what site it is it will crash after some time.

Are there some logs somewhere which could help you work it out? If so tell me and i'll post

Child Tickets

Change History (25)

comment:1 Changed 6 years ago by cypherpunks

Component: - Select a componentTor Support
Keywords: TBB crashes added
Milestone: TorBrowserBundle 2.3.x-stable
Owner: set to runa
Priority: normalcritical

I have also been experiencing this issue since updating to tbb2.3.25-8 linux 64. The vidalia logs do not show any problems or even changes when the browser crashes. The tor remains running and online. I have to manually exit and restart in order to get the browser open again. At first I thought it was potentially related to keystrokes commands, but now it is showing up randomly and often enough that it is obviously not about typing.

comment:2 Changed 6 years ago by ln5

Cc: mikeperry added

How to crash 64-bit Linux tor-browser_en-US-2.3.25-8:

  1. Unpack tor-browser-gnu-linux-x86_64-2.3.25-8-dev-en-US.tar.gz and

start it.

  1. Log on to https://wordpress.com/ (contact me for account info if

you want to use the same that i used).

  1. Press "New Post" and "Text".
  1. Click on the window where the text is supposed to be entered. On my

first three tries, FF crashed instantly. On my fourth try i managed to
type a couple of letters. When clicking on the text field again, it
crashed.

This was tested on a system calling itself 3.2.0-4-amd64 #1 SMP Debian
3.2.41-2+deb7u2 x86_64 GNU/Linux.

Extra info:

  • FF seems to be very sensitive about its extensions. Installing

"RequestPolicy" makes FF extremely crashy even without running
JavaScript.

  • Disabling NoScript and HTTPSEverywhere makes no difference.
  • Uninstalling ("Remove") NoScript and HTTPSEverywhere makes no difference.

comment:3 Changed 6 years ago by cypherpunks

Component: Tor SupportTor
Keywords: linux 64-bit added
Owner: changed from runa to ioerror
Status: newassigned

until the bug is fixed, this TBB is essentially non-functional. please fixit!

comment:4 Changed 6 years ago by cypherpunks

Status: assignednew

comment:5 Changed 6 years ago by nickm

Component: TorTorBrowserButton
Owner: changed from ioerror to mikeperry
Status: newassigned

This is a TBB bug, not a bug in Tor in Tor itself.

comment:6 Changed 6 years ago by mikeperry

Cc: gk added
Keywords: tbb-crash added; TBB crashes linux 64-bit removed

Our current guess is that these crash bugs are due to issues with the official Debian build machines, or with Debian's toolchain. Builds compiled on Ubuntu do not crash. At all.

If someone reproduces https://gitweb.torproject.org/torbrowser.git/blob/maint-2.4:/docs/buildmachine_setups/linux-x86.txt on a Debian machine and lets us know how crashy the result is, that would be a useful datapoint to tell us if it is specific to our build machines, or specific to Debian's compilers.

Again, following that same doc on Ubuntu does not produce crashy builds. Nor does following the Gitian instructions at https://gitweb.torproject.org/builders/tor-browser-bundle.git/blob/HEAD:/gitian/README.build.

comment:7 Changed 6 years ago by ln5

I've built TBB on a Debian system

Linux debian0 3.2.0-4-amd64 #1 SMP Debian 3.2.41-2+deb7u2 x86_64 GNU/Linux

I'm unable to crash that firefox. I've tried both in the VM where it
was built and in the system where I crash my TBB from the build
machine.

For a start, the list of shared libraries that firefox-bin wants
matches in the two builds (output from ldd(1), that is).

What's next? Compare various objdump outputs? A complete disassembly?

The binary can be found in
perdulce.tpo:~linus/firefox-bin.debian.20130604-1116 for those who
might want to poke at it.

15ebbe329ae8489e84970c0acda75dfa2aeaeb2d5132152c1d93a60d83adde68 firefox-bin.debian.20130604-1116

comment:8 Changed 6 years ago by ln5

Cc: erinn added

gk suggested I'd compare about:buildconfig:

-  <link rel="stylesheet" href="buildconfig-8_files/about.css" type="text/css">
+  <link rel="stylesheet" href="buildconfig-debian0_files/about.css" type="text/css">

       <td> gcc</td>
-      <td>gcc version 4.4.5 (Debian 4.4.5-8) </td>
+      <td>gcc version 4.7.2 (Debian 4.7.2-5) </td>

--g -Os -freorder-blocks  -fomit-frame-pointer</td>
+-g -fno-omit-frame-pointer </td>

       <td> c++</td>
-      <td>gcc version 4.4.5 (Debian 4.4.5-8) </td>
+      <td>gcc version 4.7.2 (Debian 4.7.2-5) </td>

--fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks
-  -fomit-frame-pointer </td>
+-std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -g 
+-fno-omit-frame-pointer  </td>

-<p>--enable-application=browser --enable-optimize 
+<p>--enable-application=browser --disable-optimize 

So I guess I'll muck about with .mozconfig or something to at least
get the flags identical.

Could somebody with access to dixie (I guess) try to figure out what
local changes was used for the linux x86_64 -8 build?

comment:9 Changed 6 years ago by ln5

Got the diff between builds down to gcc/g++ version and the following g++ flags:

--fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks
-  -fomit-frame-pointer </td>
+-std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks
+ -fomit-frame-pointer </td>

Still unable to provoke a crash.

comment:10 Changed 6 years ago by mikeperry

Owner: changed from mikeperry to erinn

erinn: It looks like this latest series of crashes are caused by --enable-optimize on Squeeze still. It seems like we either need to upgrade the stable build VM to Wheezy, or build with --disable-optimize again.

comment:11 Changed 6 years ago by mikeperry

comment:12 Changed 6 years ago by ln5

FWIW, I've uploaded my own build at https://people.torproject.org/~linus/downloads/TBB-0.2.3.25-8-ln5/ and can perhaps help other people building on Debian systems in case the information there doesn't help enough.

comment:13 Changed 6 years ago by monka_01

Not sure if this is related to this bug-report.
But opening this site (as of 7. june) immediately crashes tor-browser. Always, this link will crash the browser.

https://magazin.spiegel.de/reader/index_SP.html#j=2013&h=23&a=97012808

Using:
Tor Browser Bundle Version 2.3.25-8.
Linux 64bit, Ubuntu 12.04.2
Completely stock bundle, with no customization. Completely fresh session.

comment:14 in reply to:  10 Changed 6 years ago by arma

Replying to mikeperry:

erinn: It looks like this latest series of crashes are caused by --enable-optimize on Squeeze still. It seems like we either need to upgrade the stable build VM to Wheezy, or build with --disable-optimize again.

I imagine this has already occurred to other people, but: it seems like getting a non-crashy tbb out should be pretty high priority here.

comment:15 Changed 6 years ago by erinn

I have updated bundles here:
https://people.torproject.org/~erinn/qa/stable/2.3.25-9/

Please confirm that they do not crash for you and I will release them tomorrow.

comment:16 Changed 6 years ago by gk

The en-US bundle is still crashing for me and built with --enable-optimize. See Mike's comment (10) above.

comment:17 Changed 6 years ago by erinn

Hmm, that's strange. The mozconfig in the source tree says --disable-optimize but the one in the build tree does indeed say --enable-optimize. Not sure if the clean target did something wrong or I did. rm -rf'ing the old tree by hand this time and rebuilding again now. Thanks, gk.

comment:18 Changed 6 years ago by erinn

New one here. Triple checked the mozconfig:
https://people.torproject.org/~erinn/qa/stable/tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST.tar.gz
sha256sum: 3d7569b880ce83722fdf1f99e73814f284ad4a8edbacaf19adc605eb0ea20dfb tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST.tar.gz

comment:19 Changed 6 years ago by gk

Still the same issue: crashing and built with --enable-optimize.

comment:20 Changed 6 years ago by erinn

Ugh, I'm sorry. Combo problem of me and the build scripts: I was using the build-firefox target which doesn't copy the newly built Firefox to the right place, so it was just using the old one. I'm sorry.

I made another one and installed a 64-bit VM to test and confirmed that it has --disable-optimize. It's here:
https://people.torproject.org/~erinn/qa/stable/tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST2.tar.gz
182a3ff7b5a707cbc84c6919f3c6514e4561c583bf754df0e8c91067f6ab4f73 tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST2.tar.gz

comment:21 Changed 6 years ago by Superfluous

I reported a "Tor crashes all the time on Windows" bug here, with a patch: https://trac.torproject.org/projects/tor/ticket/8981

After applying a binary patch to xul.dll to add the logic to return 0 if mRequest is NULL, it has not crashed for me at all after about 10 days of on-and-off use throughout each day, closing and re-opening it myself just once 2 days ago. And this is the build with optimizations enabled.

comment:22 in reply to:  20 Changed 6 years ago by gk

Replying to erinn:

Ugh, I'm sorry. Combo problem of me and the build scripts: I was using the build-firefox target which doesn't copy the newly built Firefox to the right place, so it was just using the old one. I'm sorry.

I made another one and installed a 64-bit VM to test and confirmed that it has --disable-optimize. It's here:
https://people.torproject.org/~erinn/qa/stable/tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST2.tar.gz
182a3ff7b5a707cbc84c6919f3c6514e4561c583bf754df0e8c91067f6ab4f73 tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST2.tar.gz

Doing some cursory tests I don't get it to crash anymore. Looks good to me this time. :)

comment:23 in reply to:  20 Changed 6 years ago by monka_01

Replying to erinn:

Ugh, I'm sorry. Combo problem of me and the build scripts: I was using the build-firefox target which doesn't copy the newly built Firefox to the right place, so it was just using the old one. I'm sorry.

I made another one and installed a 64-bit VM to test and confirmed that it has --disable-optimize. It's here:
https://people.torproject.org/~erinn/qa/stable/tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST2.tar.gz
182a3ff7b5a707cbc84c6919f3c6514e4561c583bf754df0e8c91067f6ab4f73 tor-browser-gnu-linux-x86_64-2.3.25-9-dev-en-US-TEST2.tar.gz

Still crashing.

Try: https://magazin.spiegel.de/reader/index_SP.html#j=2013&h=23&a=97012808

comment:24 Changed 6 years ago by monka_01

Finally, it seems to be fixed with Version 2.3.25-10.
The link above does not crash tor browser anymore. Good work guys!

comment:25 Changed 6 years ago by arma

Resolution: fixed
Status: assignedclosed

I'm going to close this bug then. Thanks everyone.

Note: See TracTickets for help on using tickets.