Opened 11 years ago

Last modified 10 years ago

#899 closed defect (Duplicate)

Tor proxy broken

Reported by: abcman Owned by:
Priority: Low Milestone:
Component: Torbutton-Tor client Version: 0.2.0.31
Severity: Keywords:
Cc: abcman, arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I just installed torbutton, but when I switch to tor mode, nothing will load.

When I try to test the proxy, it comes up with "Tor Proxy Test: Internal Error" no matter what proxy settings I try.

It would be nice if the plugin actually worked out of the box as it was supposed to.

[Automatically added by flyspray2trac: Operating System: Other Linux]

Child Tickets

Change History (6)

comment:1 Changed 11 years ago by modio

I'm on Windows XP Pro SP3, and I'm getting *exactly* the same symptoms using Firefox PE.

I've also tried a completely fresh install of the latest FireFox (3.0.5) (not PE, just straight FF with the default install options) and added Torbutton (but no other add-ons) and I still get exactly the same problem.

There seems to be something seriously adrift.

comment:2 Changed 11 years ago by arma

Did you folks install the Vidalia bundle too?

Torbutton is a Firefox extension that changes your proxy settings. But
you need to actually install Tor too.

comment:3 Changed 11 years ago by nickm

ping? still there?

comment:4 Changed 10 years ago by laziaf

Hi

I am having a similar issue with Torbutton and Vidalia installed. I have installed the latest Vidalia bundle for the Mac, am using Mac OS 10.6.1 and Firefox 3.0.14. I start vidalia and it connects to the TOR network, I then start firefox and can browse with the TOR button off, when I switch the Torbutton to active I cannot browse and cannot click links on open pages. I am using the following settings for Torbutton - Proxy Settings - Use Privoxy, when I test settings, I get the following error: Tor proxy test: Internal error

I have used Vidalia / Tor / Torbutton with success using Mac OX 10.5.8

Any suggestions?

comment:5 Changed 10 years ago by mikeperry

Note to self: Its possible 1105, 1085, 1065, 1063, and 899 are all the same bug.

comment:6 Changed 10 years ago by mikeperry

flyspray2trac: bug closed.
Dupping to bug 1085. Please see that one for a fix test XPI.

Note: See TracTickets for help on using tickets.