Opened 7 years ago

Closed 7 years ago

#8996 closed defect (fixed)

HTTPS Everywhere breaks editing openstreetmap.org

Reported by: xkomczax Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug, openstreetmap
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

By clicking Edit button on openstreetmap.org loads just white page with no content. After disabling HTTPS Everywhere, everything works fine.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by pde

Resolution: duplicate
Status: newclosed

Hi xkomczax,

I believe this is a duplicate of bug #8841 . If you're seeing this in Firefox, please make sure you're running HTTPS Everywhere version 3.2.2, which should fix the problem by disabling HTTPS Everywhere protection for OSM.

If you're seeing it in Chrome, thank you for reminding us that we need to push a new Chrome release :)

comment:2 in reply to:  1 Changed 7 years ago by xkomczax

Resolution: duplicate
Status: closedreopened

Replying to pde:

Hi xkomczax,

I believe this is a duplicate of bug #8841 . If you're seeing this in Firefox, please make sure you're running HTTPS Everywhere version 3.2.2, which should fix the problem by disabling HTTPS Everywhere protection for OSM.

If you're seeing it in Chrome, thank you for reminding us that we need to push a new Chrome release :)

Thanks for reply, pde, it seems to be really duplicate. Sorry. But the problem remains even after upgrading to 3.2.2 and the only option is disabling HTTPS Everywhere on openstreetmap. I just want to add that the problem is not just with the new iD editor, but with the old Potlach2 as well.

Yes, I am using Firefox (Iceweasel 20.0).

comment:3 Changed 7 years ago by pde

Resolution: fixed
Status: reopenedclosed

Hi xkomczax, the resolution is supposed to be that the OpenStreetMap ruleset is off by default in HTTPS E 3.2.2. If you turned it on manually, I would expect the breakage to return.

I am 99% sure that most HTTPS E users should be seeing the ruleset as off now.

Note: See TracTickets for help on using tickets.