Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9008 closed defect (not a bug)

FP: Firefox can't establish a connection to ws:xxx:9000

Reported by: bastik Owned by: dcf
Priority: Medium Milestone:
Component: Archived/Flashproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Looking in the error console (what I don't do normally) I see a couple of instances of this error:

Time stamp: 01.06.2013 10:56:49
Error: Firefox can't establish a connection to server ws://[censored]:9000/.
Source: http://crypto.stanford.edu/flashproxy/flashproxy.js
Line: 444

It's Firefox 21 that shown these errors.

Does this just mean that the fellow using FP didn't set-up port forwarding or that there is a problem with my Firefox/Network/whatever?

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by arlolra

Most likely because the fellow didn't set-up port forwarding.

See the comment in this recent commit,

Many people are registering as flash proxy clients without actually being able to receive flash proxy connections, just because they are using the pluggable transports bundles.

https://gitweb.torproject.org/flashproxy.git/commit/c1768feacccd71bbba821299b95c809c82c2dee1

comment:2 Changed 4 years ago by dcf

Resolution: not a bug
Status: newclosed

Yes, what arlolra said. I don't know of a way to prevent that message from appearing in the console.

comment:3 Changed 4 years ago by bastik

Thanks. There's probably no need to prevent this. (It was just me being curious)

Note: See TracTickets for help on using tickets.