Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9031 closed defect (duplicate)

Internal Error : Tor 0.2.4.12-alpha (git-91b8bc26f160f172)

Reported by: marinaldo.jesus Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

[sex 7. jun 15:18:21 2013] Erro de software Tor - O software Tor encontrou um erro interno. Por favor reporte a seguinte mensagem de erro aos programadores em bugs.torproject.org:"microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1451867, but I should be at 1451900
"\n

jun 07 15:18:21.187 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.203 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1435541, but I should be at 1435574
jun 07 15:18:21.203 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 393): Invalid argument
jun 07 15:18:21.234 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1435940, but I should be at 1435973
jun 07 15:18:21.234 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.234 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.234 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.234 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 278): Invalid argument
jun 07 15:18:21.234 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.234 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.250 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1436327, but I should be at 1436525
jun 07 15:18:21.250 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 333): Invalid argument
jun 07 15:18:21.281 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1438314, but I should be at 1438347
jun 07 15:18:21.281 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.281 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.312 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1440584, but I should be at 1440650
jun 07 15:18:21.312 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 333): Invalid argument
jun 07 15:18:21.312 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 333): Invalid argument
jun 07 15:18:21.328 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1441310, but I should be at 1441376
jun 07 15:18:21.328 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.328 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.359 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1442091, but I should be at 1442157
jun 07 15:18:21.359 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.359 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.375 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1443102, but I should be at 1443168
jun 07 15:18:21.390 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.390 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.421 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1444099, but I should be at 1444165
jun 07 15:18:21.421 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.437 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1444459, but I should be at 1444492
jun 07 15:18:21.453 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 280): Invalid argument
jun 07 15:18:21.468 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1444786, but I should be at 1444819
jun 07 15:18:21.468 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 321): Invalid argument
jun 07 15:18:21.468 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.500 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1447102, but I should be at 1447168
jun 07 15:18:21.500 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 396): Invalid argument
jun 07 15:18:21.515 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1447462, but I should be at 1447495
jun 07 15:18:21.515 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 614): Invalid argument
jun 07 15:18:21.515 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.546 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1448975, but I should be at 1449041
jun 07 15:18:21.546 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.578 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1449948, but I should be at 1449981
jun 07 15:18:21.578 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.578 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 261): Invalid argument
jun 07 15:18:21.593 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1450641, but I should be at 1450707
jun 07 15:18:21.593 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 333): Invalid argument
jun 07 15:18:21.625 [Aviso] microdesc_cache_rebuild(): Bug: Discontinuity in position in microdescriptor cache.By my count, I'm at 1451867, but I should be at 1451900
jun 07 15:18:21.625 [Aviso] Couldn't dump microdescriptor (wrote 4294967295 out of 1886): Invalid argument
jun 07 15:18:21.625 [Aviso] Error replacing "C:\Documents and Settings\marinaldo.jesus.NALDO-PC\Dados de aplicativos\tor\cached-microdescs": Permission denied
jun 07 15:18:21.625 [Aviso] Error rebuilding microdescriptor cache: Permission denied

Child Tickets

Attachments (1)

tor_error.PNG (99.4 KB) - added by marinaldo.jesus 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by marinaldo.jesus

Attachment: tor_error.PNG added

comment:1 Changed 6 years ago by bastik

Component: - Select a componentTor
Resolution: duplicate
Status: newclosed

It should be a duplicate of #2077
(why ever it only appears on 0.2.4.12-alpha for me, but not before)

Other reports
#8822
#8883
#8922

comment:2 in reply to:  1 Changed 6 years ago by arma

Replying to bastik:

(why ever it only appears on 0.2.4.12-alpha for me, but not before)

0.2.4.12-alpha includes patches for #8037 and #8031, both of which appear related to this topic.

Note: See TracTickets for help on using tickets.