Opened 7 years ago

Closed 6 years ago

#9046 closed defect (fixed)

OS X toolbar button looks broken in Firefox with 4.0dev8

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone: HTTPS-E 4.0dev8
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 4.0dev6
Severity: Keywords:
Cc: nullishzero@…, torproject.org@…, dserodio@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I think this is related to the new counter. See the screenshot.

Child Tickets

Attachments (5)

Screen Shot 2013-06-10 at 3.37.33 PM.png (10.6 KB) - added by cypherpunks 7 years ago.
Firefox Nightly screenshot on OS X 10.7
Screen Shot 2013-08-01 at 2.18.19 PM.png (146.2 KB) - added by swrobel 6 years ago.
This is how it looks on my machine with the FXChrome theme
Screen Shot 2013-08-22 at 09.10.54.png (4.5 KB) - added by cypherpunks 6 years ago.
Button with counter, after patch
Screen Shot 2013-08-22 at 09.11.07.png (4.4 KB) - added by cypherpunks 6 years ago.
Button without counter, after patch
0001-Fix-for-issue-9046.patch (893 bytes) - added by nullishzero 6 years ago.
Patch

Download all attachments as: .zip

Change History (16)

Changed 7 years ago by cypherpunks

Firefox Nightly screenshot on OS X 10.7

comment:1 Changed 7 years ago by nullishzero

I suspect it's related to the margin and size of the counter. I don't have access to OS X, but I'll see if I can reproduce on a similar setup.

Changed 6 years ago by swrobel

This is how it looks on my machine with the FXChrome theme

comment:2 Changed 6 years ago by nullishzero

Cc: nullishzero@… added

Is there a way I can test this on a non OS X machine, such as using a certain theme? A fix that should take care of this issue has been pushed to upstream master, but I am unable to test. If someone else can pull from upstream master and test the fix, that would also work.

Changed 6 years ago by cypherpunks

Button with counter, after patch

Changed 6 years ago by cypherpunks

Button without counter, after patch

comment:3 Changed 6 years ago by cypherpunks

I've tested on OS X 10.8.4, Firefox 23 - looks like the patch fixes it for me, though the counter looks a little odd - have attached screenshots.

comment:4 Changed 6 years ago by nullishzero

This ticket can be closed.

I've opened another ticket for 'beautifying' the counter so it doesn't look out of place (https://trac.torproject.org/projects/tor/ticket/9611)

comment:5 Changed 6 years ago by zyan

nullishzero, could you make a patch for this on stable?

comment:6 Changed 6 years ago by torproject.org@…

Cc: torproject.org@… added

comment:7 Changed 6 years ago by nullishzero

Sure. The fix itself is rather trivial--I can put a patch together and do some testing in the next few days.

comment:8 Changed 6 years ago by zyan

Thanks! Let's aim to get it into the next stable release.

comment:9 Changed 6 years ago by dserodio

Cc: dserodio@… added

Changed 6 years ago by nullishzero

Patch

comment:10 Changed 6 years ago by nullishzero

Added patch for the stable branch.

comment:11 Changed 6 years ago by zyan

Resolution: fixed
Status: newclosed

Merged into 3.0.

Note: See TracTickets for help on using tickets.