Opened 6 years ago

Closed 6 years ago

#9049 closed task (invalid)

Mac OS X leaves a trace in Safari's Develop menu.

Reported by: Sherief Owned by: erinn
Priority: Very Low Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-disk-leak
Cc: runa Actual Points:
Parent ID: #6846 Points:
Reviewer: Sponsor:

Description (last modified by Sherief)

User reported on RT #10687 that he would like to remove his Tor Browser from his Mac completely but still can't remove a certain trace of the Tor browser in Safari's "Develop" menu.

To add the option to Safari's developer's menu I did the following:

  • Downloaded TorBrowser-2.3.25-8-osx-x86_64-en-US.zip and extracted TorBrowser_en-US inside the Downloads folder.
  • Used the Tor Browser a bit (amazon.com)
  • Open Safari and check the developer menu "Open Page with" inside that you should see (TorBrowser).

To remove "Open Page with (TorBrowser)" from Safari's developer menu:

  • Delete the TBB package.
  • Shutdown/Restart the system, If you don't the menu will exist until the next restart/shutdown.

Attached is a screen shot by the user.

Child Tickets

Attachments (1)

Screen Shot 2013-06-11 at 9.34.47 AM.png (77.4 KB) - added by Sherief 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by Sherief

comment:1 Changed 6 years ago by Sherief

Cc: runa added

comment:2 Changed 6 years ago by runa

Keywords: tbb-disk-leak added

comment:3 Changed 6 years ago by runa

I am not able to confirm this. Here is what I did in an attempt to reproduce:

  • Use Safari to download the Tor Browser Bundle (v 2.3.25-8, 64-bit)
  • Open the Downloads folder and click on the Tor Browser Bundle archive
  • Run the Tor Browser Bundle application from the Downloads folder
  • Use the Tor Browser Bundle
  • Close the Tor Browser Bundle
  • Move the Tor Browser Bundle to the Trash can and empty it
  • Open Safari and check the Developer menu

comment:4 Changed 6 years ago by Sherief

Description: modified (diff)
Priority: normaltrivial

comment:5 in reply to:  4 Changed 6 years ago by Sherief

Replying to Sherief:

Changed to trivial because this menu option "Open Page with (TorBrowser)" disappears if a user just deletes the TBB package and restarts the system.

comment:6 Changed 6 years ago by Sherief

Description: modified (diff)

comment:7 Changed 6 years ago by runa

I'm not sure if I would consider this a trace of TBB. The solution is pretty simple; delete TBB and restart the machine. Not sure if we can do anything about this when TBB is on the system/in use.

comment:8 in reply to:  7 Changed 6 years ago by Sherief

Replying to runa:

I'm not sure if I would consider this a trace of TBB. The solution is pretty simple; delete TBB and restart the machine. Not sure if we can do anything about this when TBB is on the system/in use.

I think I should just close this and just mention it in a wiki or something similar.

comment:9 Changed 6 years ago by Sherief

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.