Opened 7 years ago

Closed 7 years ago

#9080 closed defect (fixed)

Stem tests need a newer version of mock

Reported by: atagar Owned by: weasel
Priority: Low Milestone:
Component: Applications/Quality Assurance and Testing Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi Peter. It looks like the python-mock package you installed for stem's jenkins tests is version 0.6.0, but I'm using a feature that was introduced in 0.7.0 (current version is 1.0.1). Would you mind if we snagged it from PyPI? (pip install mock)

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by weasel

I'm not convinced that's a good idea. I think packages should be able to build without access to the network.

I notice the tests run in squeeze chroots. It'd be simple to change that to running in wheezy which should also fix your issue - http://packages.debian.org/search?keywords=python-mock

Are you abandoning support for lucid, oneric, precise and squeeze?

comment:2 Changed 7 years ago by atagar

I notice the tests run in squeeze chroots. It'd be simple to change that to running in wheezy which should also fix your issue

Great! Sounds good.

Are you abandoning support for lucid, oneric, precise and squeeze?

Mock is just a test dependency. Stem itself still only requires python 2.6+.

comment:3 Changed 7 years ago by weasel

Resolution: fixed
Status: newclosed

stem runs stuff in wheezy chroots for a while now

Note: See TracTickets for help on using tickets.