Opened 6 years ago

Closed 6 years ago

#9081 closed enhancement (duplicate)

When using DNSPort, Other Query type(MX,TXT) not resolved correctly

Reported by: ikurua22 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: DNS, DNSPort
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using DNSPort to anonymize my DNS queries.
I changed from public DNS, because of PRISM scandal.

And I found this problem:

"A" Query resolved correctly,

nslookup -type=a google.com

Address: X.X.X.X

but "MX" and "TXT" returns...

nslookup -type=mx google.com

* can't find google.com: Not implemented *

So my question is, how can I request MX and TXT over Tor DNS?
This "DNSPort" will be great alternative to public dns services, if Tor can do this.

{An idea about this problem}
How about adding "DNSRelayIP"?

sample:
DNSPort 127.0.0.1:53
DNSRelayIP 129.250.35.250
DNSRelayIP 129.250.35.251

Meaning:
User can query A,MX,TXT to Tor DNS.
Tor will query A via Tor.
Tor will query MX and TXT to "DNSRelayIP"(TCP normal traffic).

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by nickm

Resolution: duplicate
Status: newclosed

Closing as duplicate of #7829.

Note: See TracTickets for help on using tickets.