Opened 6 years ago

Closed 5 years ago

#9095 closed defect (fixed)

Microsoft Technet forums partially broken

Reported by: Quitch Owned by: pde
Priority: Medium Milestone: HTTPS-E next Firefox dev release
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug microsoft technet
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

You can view the Microsoft Technet forums, but are unable to post to them. The reply box is not displayed and the reply/quote links do nothing. The new post button is not displayed.

https://social.technet.microsoft.com

This is using the Microsoft (partial) ruleset.

I am using HTTPS Everywhere 2013.6.4 in Chrome 27.0.1453.110 m on Windows 7 Professional 64-bit.

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by mjb

I'm using the same Chrome & extension version, but it's working for me with no special config. Upon first visit I did have to click on the shield icon, which appeared to the left of the HTTPS Everywhere icon in the omnibar, and tell it to load scripts.

comment:2 Changed 6 years ago by Quitch

Wasn't aware of that, have confirmed from this side too that loading unsafe scripts via the shield icon works around the issue.

comment:3 Changed 6 years ago by zyan

Component: HTTPS Everywhere: ChromeEFF-HTTPS Everywhere

Hi, this is because of mixed content blocking in chrome and ff23+. We should add social.technet.microsoft.com to the new microsoft-mixedcontent.xml rule.

Test url: https://social.technet.microsoft.com/Forums/en-US/home

comment:4 Changed 5 years ago by bm

Milestone: HTTPS-E next Firefox dev release
Resolution: fixed
Status: newclosed

Exclusion added in 057f3545.

Note: See TracTickets for help on using tickets.