Opened 7 years ago

Closed 7 years ago

#9115 closed defect (duplicate)

Tor Browser freezes visiting www.polityka.pl

Reported by: mttp Owned by: mikeperry
Priority: High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-usability-website
Cc: mikeperry, g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This error is easy to reproduce. Go to the website and scroll around for a little while. I am using the 3.01 alpha on Windows.

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by mttp

Also happens on TBB stable.

comment:2 Changed 7 years ago by gk

Cc: g.koppen@… added
Component: Tor bundles/installationTorBrowserButton
Owner: changed from erinn to mikeperry
Priority: normalmajor

This is a Torbutton issue. Having it enabled I get:

Error: [Exception... "Could not convert Native argument arg 0 [nsIXPCComponents.results]"  nsresult: "0x8057000a (NS_ERROR_XPC_BAD_CONVERT_NATIVE)"  location: "JS frame :: jar:file:///~/tor-browser_en-US/Data/profile/extensions/torbutton@torproject.org.xpi!/components/external-app-blocker.js :: <TOP_LEVEL> :: line 135"  data: no]
Source File: jar:file:///~/tor-browser_en-US/Data/profile/extensions/torbutton@torproject.org.xpi!/components/external-app-blocker.js
Line: 135

and a lot of recursion errors thereafter. Disabling it "solves" this problem: no freeze and no additional errors in the error console.

comment:3 Changed 7 years ago by mikeperry

Keywords: tbb-usability-website added

comment:4 Changed 7 years ago by cypherpunks

Resolution: duplicate
Status: newclosed

Duplicate of #9901

Note: See TracTickets for help on using tickets.